Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 20 von 26

Thema: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

  1. #1
    Neuer Benutzer
    Registriert seit
    24.12.16
    Land
    Bitte angeben!12312312
    Beiträge
    3
    Danke: 0

    Standard LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Hallo,
    Hab seit langem wieder einmal die sounds auf dem Roboter geändert nur diesmal leider mit einer Konsequenz. Er will nicht mehr hochfahren und funktionieren. Wüsste jemand was möglich ist zu tun in diesem Fall?

  2. #2
    Neuer Benutzer
    Registriert seit
    18.12.16
    Land
    Bitte angeben!
    Beiträge
    2
    Danke: 0

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Versuch es mal hiermit:


    Zitat Zitat von Tüftl Beitrag anzeigen
    So, hier ein Rettungsscript, mit dem man die /usr/etc/rc.local wieder herstellen kann, wenn deswegen der Homebot nicht mehr startet.

    Anhang 8683

    1. Den Inhalt der .ZIP Datei entpacken
    2. Die Dateien auf einen leeren FAT-Formatierten USB-Stick kopieren.
    3. Die Datei Lies-mich.txt öffnen und lesen und entsprechend dieser Anleitung vorgehen.

    Code:
    Lies-mich.txt        Anleitung und Informationen. Als erstes Lesen.
    rc.local             Die original Datei. Diese Datei bitte verwenden und keine Veränderte.
    root_update.sh       Das eigentliche Rettungsscript.
    Viel Glück.
    Tüftl

  3. #3
    Neuer Benutzer
    Registriert seit
    24.12.16
    Land
    Bitte angeben!12312312
    Beiträge
    3
    Danke: 0

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Vielen vielen Dank und Frohe Weihnachten

  4. #4
    Profi Benutzer
    Registriert seit
    03.11.13
    Land
    Bayern
    Beiträge
    973
    Danke: 107

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Hi,

    Wenn der Hombot nicht mehr hoch fährt (bootet), kann das mehrere Ursachen haben.
    Wenn man an der Software gebastelt hat und nun plötzlich hängt, dann probiert man es am besten zuerst mit der Anleitung unter Bootschleife nach Update, homebot bricked - boot loop.
    Denn eine häufige Ursache ist, dass man sich die /usr/etc/rc.local oder eine der darüber aufgerufenen Dateien zerschiesst. Oder die Zugriffsrechte bei Scriptdateien falsch oder nicht setzt.

    Ein weitere Fehlermöglichkeit ist, das der Hombot bzw. dessen Steuerungssoftware ( /usr/rbin/rpmain.axf ) abprüft ob auch auf dem Rechner im SOC des IO-Board die dazu passende IO-Steuerungs-Software läuft. Man man z.B. nur eine neuere Steuerungssoftware (rpmain.axf) aufspielt, dann passen die beiden Versionsstände nicht mehr zusammen und der Hombot verweigert seinen Sienst.
    Das Repariert man am einfachsten, indem man ein offizielles Softwareupdate durchführt. Auf die Version die der Hombot original drin hat.
    Allerdings haben manchmal die allerneuesten Modelle eine neuere Software als man herunterladen kann. Dann benötigt man ein Fullbackup von seinem Hombot. Aus diesem extrahiert man dann die Dateien aus dem Verzeichnis /usr/rbin/ un kopiert diese auf seinen Hombot. Damit passen dann die Versionsstände wieder zusammen und die Kiste läuft wieder.

    Als dritte Fehlerursache - die es bislang hier nur einmal gegeben hat ist, das es aus einem unbekannten Grund das Dateisystem des Hombot zerschossen hat. Die Gefahr besteht dann, wenn man das Ende eines update nicht abwartet und zu früh abschaltet, das Update extrem fehl schlägt, oder der Speicherbaustein (Nand-Flash) einen Fehler hat.
    Hier muss man dann genauere Analyse betreiben und dann per Holzhammermethode das passende Image zurückspielen.

    Und dann kann auch mal etwas passieren, wenn der USB-Stick fehlerhaft ist.

    Hast Du nur neue Sounddateien in den Hombot geladen?
    Wie (USB Stick oder Funktion vom Hack - neue Oberfläche)?

    Probier zuerst mal die erste Möglichkeit aus. Das repariert zerschossene Scripte.
    Wenn das nicht hilft, dann mache vom aktuellen Stand zuerst ein FullBackup und Vergleiche was für eine Version dein Hombot hat. Ist das gleich öder älter als das was man als offizielles Update bei LG herunterladen kann, dann mache ein offizielles Update. Das reperiert dann weitere Dateien

    Hat dein Hombot eine neuere Version oder geht es mit dem Update auf die eigene Version nicht, dann muss man nachschauen was los ist.

    Gruß Tüftl

  5. #5
    Neuer Benutzer
    Registriert seit
    24.12.16
    Land
    Bitte angeben!12312312
    Beiträge
    3
    Danke: 0

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Vielen Dank für die schnelle Antworten, ich habe das Rettungsscript mit einem USB stick der diesmal funktionierte ausgeführt und alles ist wieder wie früher. Der Hombot funktioniert wieder. Hab auch das neuste Update vom 8.8.2016 drauf. Danke nochmals und frohe Weihnachten.
    Dominik

  6. #6
    Neuer Benutzer
    Registriert seit
    24.12.16
    Land
    Deutschland
    Beiträge
    10
    Danke: 0

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Hallo Tüftl und andere Mitglieder,

    mein Hombot VR6340LV wurde nach Anleitung mit dem WLAN Hack ausgestattet und neue Sounds per WinSCP aufgespielt. Alles war wunderbar und funktionierte einwandfrei. Nach ca. einem halben Jahr Nutzung wurde der HomBot für gefühlte 2 Monate nicht benutzt und war stromlos. Zwischenzeitlich hatte ich mir ein neues Netzwerk eingerichtet, wodurch der HomBot keinen Zugriff mehr auf mein Netzwerk hat.

    Der erste Startversuch ergab eine Ansage der letzten beiden IP Stellen, welche jedoch nicht in meinem Netzwerk (Fritz Box) angezeigt werden mit anschließender Bootschleife. Nach Entfernen des WLAN Sticks und Neustart sagt der HomBot garnix und hängt in der Bootschleife. Dh. mit Stick -> IP und Bootschleife, ohne Stick -> keine Ansage und Bootschleife.

    Habe das komplette Forum durchforstet und schon alle Rettungsscripte (z.B.: Bootschleife nach Update, homebot bricked - boot loop) versucht, ohne Erfolg. Die Dateien "usr-Dateien.txt" und "Dateiliste.txt" werden danach auf dem Stick angezeigt, aber das offizielle LG Update 16552 wird vom Bot erkannt, angefangen und dann als "Update fehlgeschlagen" abgewiesen.

    Des Weiteren scheint der USB Stick zu funktionieren, da ein erneutes Aufspielen des WLAN Hacks mit "here we go" und "complete"vom Bot quittiert wird. Leider bleibt auch hier der selbe Zustand wie bereits oben beschrieben (Bootschleife mit und ohne WLAN Stick).

    Jetzt meine Frage:

    Kann ich den Bot zwingen ein neues Firmware Update aufzuspielen?

    Vielen Dank und beste Grüße

    Stefano

  7. #7
    Profi Benutzer
    Registriert seit
    03.11.13
    Land
    Bayern
    Beiträge
    973
    Danke: 107

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Kann ich den Bot zwingen ein neues Firmware Update aufzuspielen?
    Wenn er beim Update mit "Update fehlgeschlagen antwortet, nein.

    Der erste Startversuch ergab eine Ansage der letzten beiden IP Stellen, welche jedoch nicht in meinem Netzwerk (Fritz Box) angezeigt werden mit anschließender Bootschleife.
    Wenn er Zahlen ansagt, dann hatte er eine Verbindung zu irgend einem WLan.

    ... und schon alle Rettungsscripte ... versucht, ohne Erfolg.
    Das ist nicht gut. Da heist es zuerst die Fehlerursache festzustellen. Alles andere kann unter Umständen noch mehr Schaden anrichten.

    Ich gehe mal davon aus, dass Du den Hack neu aufgespielt bzw. die Datei wpa.conf bearbeitet und neu installiert hast.
    Hatte er danach die Bootschleife, oder erst nachdem Du ein Update versucht hattest?

    Kannst Du ein FullBackup erstellen?
    Das funktionierende Script dazu findest Du hier. "Suche Backups zwecks Vergleich ..." #23.
    Auf dem Stick werden dabei allerlei Dateien abgelegt. Interessant ist zur Fehlersuche jetzt erstmal nur die Datei "dmesg.txt" und die df.txt.

    Kannst Du die hier reinsetzen?

    Gruß Tüftl

  8. #8
    Neuer Benutzer
    Registriert seit
    24.12.16
    Land
    Deutschland
    Beiträge
    10
    Danke: 0

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Guten Abend Tüftl,

    erstmal vielen Dank für deine schnelle Antwort!

    Ja, den Hack habe ich versucht neu aufzuspielen und es es schien auch alles zu funktionieren. Testweise habe ich dem Bot aber nun die IP Endnummer 19 statt 24 gegeben und trotzdem spuckt er mir die 24 beim Start aus... Richtig, dazu habe ich die wpa.conf und die wificonn.sh gemäß Anleitung bearbeitet.
    Die Bootschleife existiert seitdem ich den Bot nach längerer Standzeit wieder eingeschaltet habe dauerhaft. Egal ob ich den Hack neu aufspiele, die Rettungsscripte durchfahre (wobei ich nicht glaube das er diese "annimmt" da er nix dazu sagt) oder das Update versuche.

    Übrigens kommt die IP Endnummer nur bei eingestecktem WLAN Stick. Ohne Stick sagt er nichts und bootet endlos..

    Ein Fullbackup habe ich soeben erstellt und lade die beiden interessanten Dateien hier hoch.

    Vielen vielen Dank schonmal fürs kümmern!

    BG

    Stefano

    dmesg.txt
    df.txt

  9. #9
    Profi Benutzer
    Registriert seit
    03.11.13
    Land
    Bayern
    Beiträge
    973
    Danke: 107

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Die gute Nachricht ist, das Dateisystem ist in Ordnung und nichts zerschossen.

    Die schlechte Nachricht ist, irgendwo hat sich sehr viel Datenmüll angesammelt, so das eine Partition zu 100 Prozent gefüllt ist. Und daher macht die Software einfach .

    Was das können wir über die Datei "Dateiliste.txt" feststellen.

    Gruß Tüftl

  10. #10
    Neuer Benutzer
    Registriert seit
    24.12.16
    Land
    Deutschland
    Beiträge
    10
    Danke: 0

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Na das hört sich doch schon mal gut an.

    Ich weiß zwar nicht wie Du aus den ganzen Hieroglyphen etwas rausliest aber bitte mach weiter damit

    Hier die Datei.

    Besten Dank und viele Grüße!

    Dateiliste.txt

  11. #11
    Profi Benutzer
    Registriert seit
    03.11.13
    Land
    Bayern
    Beiträge
    973
    Danke: 107

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Die Ursache und Lösung ist ganz einfach.
    Du hast einfach von allen Sounds eine Kopie auf dem Hombot angelegt.

    /usr/Orig Sounds/SNDDATA:

    Damit war dann fast der gesamte Speicherplatz von /usr belegt. Und dann wurde ein Sound durch einen getauscht der etwas größer war, und Wups ist nun zu wenig Speicherplatz übrig.
    Und scheinbar war seit dem kein Neustart mehr nötig.

    Die Lösung ist, einfach. Den Hack installieren, per WinSCP draufgehen und die Sounds aus dem Kopie-Verzeichnis ( /usr/Orig Sounds ) runterladen und auf dem Hombot löschen. Also alles was sich in /usr/Orig Sounds/ befindet.
    Im übrigen solltest Du alle Sounds auch im Fullbackup haben. Öffne das BackAll.tar. Dort solltest Du auch alle finden.

    Gruß Tüftl

  12. #12
    Neuer Benutzer
    Registriert seit
    24.12.16
    Land
    Deutschland
    Beiträge
    10
    Danke: 0

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Das hört sich auf jeden Fall schon mal gut an

    Das Problem ist allerdings, dass wenn ich versuche den Hack erneut aufzuspielen dieser das zwar mit "here we go" und "complete" quittiert, jedoch beim nächsten Start immernoch die IP Stelle 24 genannt wird und nicht das was ich über den Hack programmiere, zB. 19. Verbunden ist der Bot jedenfalls nicht sodass ich auch nicht per WinSCP darauf zugreifen kann...

    Kann es sein, dass weil der Speicher voll ist der Hack garnicht wirklich installiert bzw. gespeichert werden kann?

    Gibt es nicht ein Script um die Orig Sounds zu löschen? Habe diese auch extern auf meinem Rechner gespeichert

    Vielen Dank!

    Gruß

    Stefano

  13. #13
    Profi Benutzer
    Registriert seit
    03.11.13
    Land
    Bayern
    Beiträge
    973
    Danke: 107

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Kann es sein, dass weil der Speicher voll ist der Hack garnicht wirklich installiert bzw. gespeichert werden kann?
    Ja, das ist möglich.

    Gibt es nicht ein Script um die Orig Sounds zu löschen?
    Bisher nicht, denn ausser dir weiss ja niemand wohin du die original-Sounds als Kopie gespeichert hast.

    Aber hier ist eines speziell für dich.

    Loeschscript.zip

    Inhalt des Archives auf einen Stick.
    Soundausgabe ist: 3 2 1 Complete

    Gruß Tüftl

  14. #14
    Neuer Benutzer
    Registriert seit
    24.12.16
    Land
    Deutschland
    Beiträge
    10
    Danke: 0

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Whoooa Du bist ja echt ein netter Mensch Vielen Dank!

    Habe es direkt drüber laufen lassen. Hat auch runtergezählt 3,2,1 complete.

    Hier die Logfile

    Loesch_Log.txt

    Nur leider fährt er immernoch nicht hoch... xD selbes Spiel wie vorher. Kann es sein, dass der Path nicht stimmt?

  15. #15
    Profi Benutzer
    Registriert seit
    03.11.13
    Land
    Bayern
    Beiträge
    973
    Danke: 107

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Der Pfad stimmt, jedoch wurde der * nicht expandiert.

    Hier eine korrigierte Version.

    Loeschscript2.zip

    Gruß Tüftl

  16. #16
    Neuer Benutzer
    Registriert seit
    24.12.16
    Land
    Deutschland
    Beiträge
    10
    Danke: 0

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Hallo Tüftl,

    vielen Dank für die Hilfestellungen bin dir wirklich sehr dankbar!

    Habe das zweite Script drüberlaufen lassen und folgende Datei zurückbekommen.

    Loesch_Log.txt

    Der Zustand des Bots ist nach wie vor derselbe

    Hast Du noch ein Ass im Ärmel? ^^

  17. #17
    Profi Benutzer
    Registriert seit
    03.11.13
    Land
    Bayern
    Beiträge
    973
    Danke: 107

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Hmm, readonly Filesystem beim Löschen, das klingt nicht gut und steht im Widerspruch zu der Ausgabe von der dmesg.txt Ausgabe.

    Kannst Du nochmals neu das Fullbackup laufen lassen und die dmesg.txt hochladen?

  18. #18
    Neuer Benutzer
    Registriert seit
    24.12.16
    Land
    Deutschland
    Beiträge
    10
    Danke: 0

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Na klar,

    hier die neue Datei.

    dmesg.txt

    Übrigens hatte er beim ersten Fullbackup 233MB auf den Stick kopiert und eben 386MB! Glaube der Bot frisst nur noch ohne mal zu

  19. #19
    Profi Benutzer
    Registriert seit
    03.11.13
    Land
    Bayern
    Beiträge
    973
    Danke: 107

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Das ganze gibt mir nun echt zu rätseln.

    Übrigens hatte er beim ersten Fullbackup 233MB auf den Stick kopiert und eben 386MB!
    Du hast den Stick gelöscht indem Du die Dateien in den Windows Mülleimer befördert hast.
    Wenn Du dir von diesem Stick die Eigenschaften anzeigen lässt, dann hat er keine 8 GB frei, sondern zeigt nur etwas mehr als 7 GB als frei an. Stimmts?
    Der Mülleimer des USB-Sticks ist mit in das Fullbackup gewandert.

    Egal, lass uns nochmal etwas probieren.

    Ich versuche hier einfach auf verschiedene Möglichkeiten eine der Sounddateien zu löschen.

    Loeschscript3.zip

    Und noch eine Besonderheit, ich lese diverse Daten des USB-Stick und was drauf ist mit anzeigen.
    Wenn Du das nicht willst, dann lösche die Datei "usbinfo". Oder entferne einfach das was in der "Loesch_Log.txt" zwischen den ersten beiden " ******************* " Zeilen steht.

    Wenn alles durchläuft, dann müsste er von 9 - 1 herunterzählen, complete sagen und evtl. am Ende den Robbi auch ausschalten.
    Ach ja, den Robbi nicht in die Ladestation stellen, sonst startet er wieder durch, falls das mit dem Ausschalten funktioniert.

  20. #20
    Neuer Benutzer
    Registriert seit
    24.12.16
    Land
    Deutschland
    Beiträge
    10
    Danke: 0

    Standard AW: LG Hom-Bot VR6270LVMB will nicht mehr hochfahren

    Super, vielen Dank!

    Also er hat runtergezählt und folgendes ausgespuckt.

    Loesch_Log.txt
    Dmesg.txt

    Runtergefahren ist er nicht... steht auch nicht in der Ladestation.

    Nochmals vielen vielen Dank, dass Du soviel Gehirnschmalz in mein Problem steckst!

    Beste Grüße

    Stefano

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •