Sr8855 c01

  • Hallo,
    ich habe einen Samsung Navibot SR8855 gebraucht erstanden.
    Dieser hat bis heute morgen brav seinen Dienst getan und ist dann plötzlich mit dem Fehler C01 stehen geblieben.


    Ok, nicht so schlimm dachte ich!
    Hab den Robi gereinigt, sogar das Trommelgehäuse ausgebaut und sauber gemacht.
    ABER was soll ich sagen ?! Immer noch Fehler C01.


    Ich habe dann den Selbsttest laufen lassen und dabei folgendes festgestellt:


    Die Walze wechselt nach kurzer Zeit immer die Drehrichtung - das kann doch so nicht richtig sein ?
    Kann mir jemand einen Tipp geben ???
    Was könnte defekt sein ?


    Gruß
    mschmitz

  • Hallo,
    das habe ich mir schon durchgelesen ...
    C01 bleibt, wie gesagt meine Bürste verhält sich merkwürdig ...
    Ist es richtig, dass die Bürste ständig die Richtung wechselt ??
    Normalerweise müsste sie sich doch immer in eine Richtung drehen oder ?

  • wie verhält er sich ohne Bürste?

  • ich kann es dir leider nicht genau sagen, ich würde vermuten, das etwas den Bürstenmotor blockiert.


    Vielleicht kann User glnc222 da besser helfen.

  • ich hatte die komplette Bürsteneinheit auch schon ausgebaut und gereinigt.
    Den Motor habe ich auch ausgebaut - quietscht beim drehen etwas, ansonsten dreht er sich aber leicht.

  • Hallo nochmal in die Runde,


    ich habe das mal auf Video festgehalten, damit man versteht was ich meine...
    Hier der Link zum Video:
    https://youtu.be/mZ-9qBr3cJ0


    Das ist eine kurze Aufnahme aus dem Testmodus "Sensor Check 6" Sensor Selection 02 Power Brush Motor.
    Hier steht: When the Motor ist rotating : "02 RPM Increasing" ....
    When the Motor ist defective : "02 0"


    Ich bin da ja irgendwo dazwischen :-)


    Die Stromaufnahme habe ich auch kurz gemessen: ca. 140 mA im Anlauf sind es ca. 240 mA


    Gruß
    mschmitz

  • I received your Private Message on this question.
    Motors are powered by pulsed currents from the circuit boards to control rpm -- Pulse Width Modulation (PWM). The components can reverse a motor by changing the polarity of the voltage. Note how the drive wheel motors can move both forwards and backwards.
    The software and the computer controls the motor drive components. Special IC's may be used to drive the motors. It is difficult to indentify which circuit component is defective without the circuit design schematic diagrams and part specifications. Expert engineers might be able to trace the circuits.
    The computer software may have an error. Parts and circuit boards are available at samsungparts.com. For such an old device it may not be economical to replace many parts.
    The wires to the motor might be examined with a volt meter to observe whether the polarity is being reversed.



    It is theoretically possible the software reverses the brush motor in response to some obstacle or blockage stopping the brush. The computer senses the motor rpm and detects when the brush is blocked. Error messages are displayed for such blockage. The software might use a strategy of reversing the motor to possibly eject blocking debris.
    A defective motor or drive belt slipping might cause a stoppage to be detected and trigger the software and error message. The details of the motor use is not published by Samsung. There could be dirt in the drive belt assembly blocking the motor. Drive belts can wear out. Examine all the parts.

  • Folgendes habe ich ja bereits gemacht.


    - die Trommeleinheit komplett gereinigt.
    - im Testmodus den Motor gemessen (hier erfolgt eine Umkehr der Spannungen.


    Folgende Überlegungen von mir:
    Der Motor muss ja einen "Tacho" haben um seine Umdrehungen an die Platine zu melden ?!?! Eventuell ist dieser defekt.
    Die Platine hat im Bereich der Motorsteuerung ein defektes Bauteil , hier kommen nur die FDS4897C und der 74HC08A in Frage.
    Die Software hat einen Bug.


    Ansonsten fällt mir nicht mehr viel ein.


    von den Bauteilen auf der Platine liege ich bei ca. 14,- € ... Ob sich der Aufwand lohnt ???


    Gruß
    mschmitz


    Hello glnc222,
    Thank you for your answer.



    I've already done the following.



    - completely cleaned the drum unit.
    - Measured the motor in the test mode - there is a reversal of the voltages.



    The following considerations from me:
    The engine must have a "speedometer" to report its revolutions to the board?!?! Maybe this is broken.
    The board has a defective component in the area of the motor control (FDS4897C and 74HC08A).
    The software is buggy.





    mschmitz


  • A defect in the rpm sensor on the motor would report false blockages to the cpu.
    The sensor signal could be analyzed with instruments, maybe a frequency scale on multimeter,oscilloscope. Not an engineer. Sensor usually a magnetic disk and detector.


    Roomba's had a feature to reverse the brush to eject cables on the floor picked up.

  • FDS4897C Power Transistor data sheet https://www.fairchildsemi.com/datasheets/FD/FDS4897C.pdf
    MC74HC08A Logic AND gate (4 on IC) data sheet http://www.onsemi.com/pub/Collateral/MC74HC08A-D.PDF



    Driver for motor controlled by cpu inputs. Inputs to the AND gates will be on/off signals 5v or ground.
    Not clear where the RPM sensor is wired.


    Search part numbers at distributor digi-key.com

  • so,
    ich habe mich entschlossen die Motortreiber auf dem Mainboard zu tauschen.
    Teile sind bestellt - ich werde berichten wenn ich Sie eingebaut habe. (nicht vor dem 21.02.18)


    Gruß
    mschmitz

  • The RPM sensor for the motor or the circuit connected could be at fault. A false blockage could be detected, causing a reversal of direction to eject debris.
    Robots can be supported on books with the wheels free to observe motor operation. In some robots the suspension arm must be taped down to prevent activating a switch sensing lifting the robot off the floor.

  • Hallo,


    so ich vermute, dass der HALL-Effekt-Sensor defekt ist.


    Auf dem Bürstenmotor befindet sich ein Hall-Effekt-Sensor und auf den Antriebsrädern gibt es jeweils zwei von diesen Sensoren (diese könnten bei anderen Fehlern defekt sein).


    Als Ersatz habe ich mir den A1101ELHLT-T herausgesucht. Ich werde weiter berichten, wenn ich ihn bekommen und eingebaut habe.

    Files

    • DSC_0046.jpg

      (132.31 kB, downloaded 18 times, last: )

    Indego 1200 connect