Landroid scheint offline zu sein - und verstellt die Uhrzeit

  • Ich habe meinen Landroid M500 nun etwas über eine Woche in Betrieb. Ich erreiche ihn über die App aber nur sehr sporadisch (um es mal positiv auszudrücken), obwohl ich ihn im Router sehe. Auch ist er heute schon das zweite Mal nicht rechtzeitig gestartet; liegt wohl daran, dass er die Uhrzeit falsch synchronisiert?

    Anbei mein Log, ist da was ersichtlich?

  • Das er verspätet startet könnte aber auch daran liegen, dass er erst sein Akku voll macht bevor er los mäht. Das mit der App ist so eine Sache. Entweder dein Landroid hat wirklich keine Verbindung oder manchmal geht das mit der App nicht richtig. War in den letzten Wochen oft Thema im Forum.

    Gruß Martin

  • Hhmm, ich habe das Logfile aber um ca. 18:30 gezogen; laut Log aber hatte der Roboter 17:02 Uhr, oder sehe ich das falsch?

    Akku ist voll.

    Auch die DeskApp verbindet sich nicht, wenn die Smartphone App keine Verbindung hat. Trotzdem scheint er im Router als verbunden auf...


    Grüße

    Georg

  • Ich bekomme heute auch schon den ganzen Tag keine Verbindung (letzte Aktualisierung 09.05.2019 00: 58:31). Im WLAN und per ping ist der M500 aber problemlos erreichbar.

  • Bei mir gibt es keine Probleme mit der Anbindung und der App.


    Bei mir ist eher das Problem, dass es seit gestern ständig regnet und daher mein Robbi nicht fahren kann. Es soll ja auch nicht den Rasen umgraben. Andererseits hält sich der Rasen nicht an die Waffenruhe und wächst munter weiter....

  • Zum x-ten, die aktuelle Android App (kA ob auch IOS) macht was falsch. Sie verwirft ihr Objekt nicht und somit wird eine alte Zeit gesetzt, wenn man selber aktualisiert (wisch runter).

    Dies ist eine gefestigte Vermutung, da es durch Analyse von mehre Logbücher unterschiedlicher Benutzer und dem davor kommenden Mqtt Recv aus Sicht des Mähers eindeutig korreliert.


    Falls Du also einen zeitlich gesicherten Betrieb willst, dann nicht nach unten wischen und den Mähplan mit der DeskApp, inkl. Zeitfehler, eingeben.

    Im Fall das es Samstag wirklich den ganzen Tag regnet komme ich vielleicht dazu in der DeskApp einen Button zur Einstellung der Zeit einzubauen ...

    Landroid SB450 Gustav - WR102SI - Firmware 3.51 - App 1.1.12 - ca. 550m²
    Entwicklungsprojekte ==> DeskApp, Analyser
    Erst Lesen, dann Fragen ==> FAQ - Allgemein

  • Wenn die Zeit am Mäher verstellt ist, reicht es die App zu killen (z.B. in der Taskanzeige "Alle schließen"). Ein Anschließender Neustart der App mit Verbindungsaufbau korrigiert die Zeit am Mäher wieder.

    ...komme ich vielleicht dazu in der DeskApp einen Button zur Einstellung der Zeit einzubauen ...


    Das wäre super. Und vllt. auch eine Möglichkeit schaffen, mit der diese Zeiteinstellung auch von den Plugins zugänglich ist? :*:lol:

  • Vielen Dank für die Antworten!

    Die mangelhafte/fehlende Verbindung ist also das Problem vom Server von Worx und kann ich nicht beeinflussen? Oder weist mein Logfile auch auf ein Problem mit der Verbindung zum Router hin?

  • Häh, geht doch sowieso, du musst es nur im richtigen Format "uk" tun und "lg" was sowieso net geht ignorieren. :/


    Und Du bist vergangen ...

    Code
    1. "cfg":{ "tm":"16:30:50", "dt":"07/05/2019" }

    Landroid SB450 Gustav - WR102SI - Firmware 3.51 - App 1.1.12 - ca. 550m²
    Entwicklungsprojekte ==> DeskApp, Analyser
    Erst Lesen, dann Fragen ==> FAQ - Allgemein

  • Hier nochmal eine signifikante Stelle aus dem Log von georgw

    Code
    1. #00124 - 09/05/2019 15:17:40 - [wifi] - sending mqtt message payload: 483, type:r
    2. #00125 - 09/05/2019 15:17:40 - [RTC] - Time changed from iot web platform
    3. #00126 - 09/05/2019 15:21:51 - [wifi] - mqtt ready! waiting messages
    4. #00127 - 09/05/2019 15:21:51 - [wifi] - mqtt message sent successful
    5. #00128 - 09/05/2019 15:21:49 - [wifi] - sending mqtt message payload: 481, type:l


    Auf 15-17-40 stellt es mehrfach zurück. (shit smileys - wie schaltet man des ohne code ab?)


    Ansonsten würde ich sagen eine ganz normaler Garten mit nicht ganz 100% WLAN-Abdeckung.

    Diese ist aber ja auch nicht notwendig. Also eine paar Mqtt lost und reconnect auf der Fläche sind voll OK.

    Ist bei mir auch im hintersten Winkel oder hinter dem Schuppen.

    Landroid SB450 Gustav - WR102SI - Firmware 3.51 - App 1.1.12 - ca. 550m²
    Entwicklungsprojekte ==> DeskApp, Analyser
    Erst Lesen, dann Fragen ==> FAQ - Allgemein

  • Hatte auch immer wieder Verbindungsprobleme. Habe gestern im Router 5 GHz ausgestellt. App und Verbindung funktioniert jetzt 100%ig.

    WG 790E seit 2015 mit Räderumbau auf bisher 450m² jetzt 150 m² Rasenfläche

    WR 141E mit 4Ah Akku seit Anfang April 2019 auf 300 m² Rasenfläche

  • Häh, geht doch sowieso, du musst es nur im richtigen Format "uk" tun und "lg" was sowieso net geht ignorieren. :/


    Und Du bist vergangen ...

    Oh wie peinlich. Ich vergehe!

  • Quote

    [RTC] - Time changed from iot web platform

    Das könnte man fast so interpretieren, dass sich der Landroid die Zeit vom MQTT-Server von Worx holt? Wenn der in einer anderen Zeitzone wäre oder sonst die Zeit auf dem Server nicht richtig wäre, hätte dann der Robbi eine falsche Zeit.

  • Bei meinem M500 habe ich keinerlei Probleme mit der Systemzeit. Die ist korrekt. Die Log-Zeiten stimmen.

    Die Meldungen "[RTC] - Time changed from iot web platform" haben bei mir die Systemzeit nicht negativ verstellt.


    Und ich nutze auch die Original Android-App. Macht also bei meinem Landroid keinen Mist.

  • Hatte auch immer wieder Verbindungsprobleme. Habe gestern im Router 5 GHz ausgestellt. App und Verbindung funktioniert jetzt 100%ig.

    Der Tag ist noch jung. Meine App funktioniert prima in Vollmondnächten;)

    Landroid S WR106 seit 6/17 - FW3.40 - 200m² - Einfachgrundstück
    Landroid M WR111 seit 8/17 - FW5.21 - 700m² - Buckelhangpiste
    iobroker auf RaspberryPi mit Adapter 'Worx' von Meistertr für Positec S-M-L-Kress Modelle

    iRobot Roomba 650

    FAQ Allgemein lesen hilft

  • Das die Zeit vom Landroid um einen kleinen Betrag bzw. bei dem ersten Kontakt oder nach FW-Upgrade um einen größeren verstellt wird ist vollkommen OK. Das es die Android bei jedem Zugriff (und hier vor allem bei der Aktualisierung) tut ist leider etwas überzogen. Solange das Objekt immer zeitnah erstellt wird und nicht auf etwas altes zurück gegriffen wird geht es halt gut. Leider klappt es nicht bei allen. Ob das nun an der Android Version oder sonstwas liegt ist egal. Ein explizites Stellen der Systemzeit durch eine bewusste Interaktion vom Anwender würde den Fehler beheben.

    Die DeskApp schickt zum Aktualisieren (Poll) ein leeres MqttJson, bei der Android App ist da die "aktuelle" Zeit drin.

    Landroid SB450 Gustav - WR102SI - Firmware 3.51 - App 1.1.12 - ca. 550m²
    Entwicklungsprojekte ==> DeskApp, Analyser
    Erst Lesen, dann Fragen ==> FAQ - Allgemein

  • Häh, geht doch sowieso, du musst es nur im richtigen Format "uk" tun und "lg" was sowieso net geht ignorieren. :/


    Und Du bist vergangen ...

    Code
    1. "cfg":{ "tm":"16:30:50", "dt":"07/05/2019" }

    Sorry, da verstehe jetzt aber mal gar nichts...




    Ich habe nur in einem Teil meines Gartens WLAN, das ist aber überhaupt kein Problem. Bei der Ladestation hätte ich aber WLAN und eben da habe ich das Problem, dass mein Roboter so gut wie nie erreichbar ist. Weder zum manuellen Starten noch zum Ändern der Zeitpläne (erscheint immer "Landroid scheint offline zu sein").