Umbau Ambrogio L250 Elite auf 2 Akkus (S+ Version) in 30 Minuten

  • Moin,



    wie im Robotan-Thread besprochen, hier die Photos von dem Umbau des L250 Elite mit 1*25V/7.5Ah Akku auf 2*25V/6.9Ah. Benötigt werden:


    • Schraubenzieher (Sechskant, zwei Größen)
    • 1 * Ambrogio C0069 (Schraube)
    • 1 * Ambrogio 110Z12900 (Batterieklammer)
    • Schaumstoff
    • Seitenschneider

    L250 öffnen (die beiden Batterieladestutzen abdrehen, beide runde Metallblenden oben abdrehen, Deckel abnehmen, Notstop-Kabel am Verbinder trennen, die vier Teller abnehmen (auf FRONT-Beschriftung achten), 6 Sechskantschrauben ausdrehen, hochklappen) = 5 Minuten


    Alten Akku abklemmen und entfernen. Das im Roboter enthaltene Kabelset ist schon für den zweiten Akku vorbereitet - dort den Kabelbinder durchtrennen. Rechtes Batteriefach mit Schaumstoff auslegen, zweite Batterie rein, Klammer aufschrauben und wieder zusammenbauen = 25 Minuten.


    Die Akkus kamen von Amazon (ASIN B00UFH2JI4, Hersteller vhbw) und waren voll geladen. Lieferzeit ca. 3 Tage. Ich hatte die Batterieklammer nicht vorrätig - daher ist das eine Behelfslösung zu sehen...


    Roboter angeschaltet und ist losgefahren. Muß ihn noch auf 6h mähen umprogrammieren heute abend...


    Bei Fragen bitte fragen.


    Ciao, -MN

  • Nachtrag: es gibt eine software-basierende Beschränkung: der Mäher fährt nach etwa 3:30h (maximale im Katalog angegebene Mähzeit) zur Ladestation. Dort ruht er sich kurz aus (10-15 Minuten) und fährt dann wieder los...


    Ich kann damit leben...


    Ciao, -MN

  • Also doch eine Blockierung drin.

    Wiper geschädigter mit einem

    Ciiky Xh My 17 7030 ELO

    Ciiky XH My 14-16 5030 ELO


    Gforce 600 im Anfangsstadium

  • Also doch eine Blockierung drin.

    Es kann auch einfach das Batteriemanagement sein. Die originalen Akkus kamen mit 7.2Ah, die neuen haben nur 6.8Ah. Es dauert evtl. einfach, bis das Batteriemanagement sich an die Ladekurven anpasst...


    Letzte Woche war er auf 8:30-20:30 mähen programmiert und arbeitete sehr sehr lange und wechselte auch prima zwischen den Zonen....


    Ciao, -MN

  • Update nach gut 6 Wochen:


    "Dexter" ist gerade nach 6h:15m zurück auf dem Weg in die Ladestation. Die Displayanzeige hinten zeigt noch 2 von 3 Balken Kapazität.


    Es gibt definitiv keine Software-Sperre - ABER die Firmware hält vermutlich Daten über Batteriekapazität und Dauer für die sichere Rückfahrt. Nach dem Akku-Umbau habe ich diese Daten (mangels Händler-App) nicht löschen können und "Dexter" mußte sich jeden Tag mehr an die tatsächliche Kapazität herantasten und diese Werte aktualisieren. Am Anfang ist das ganze sehr frustrierend...


    Firmware 44011 ist eine Katastrophe. Aktuell läuft 44111 (?) und die Mähzeiten sind auf lange Blöcke (Start 8:00 bis 20:30) eingestellt. Seitdem fährt Dexter sauber zum aufladen und wieder los.


    Was nicht geht sind mehrere Mähzeiten und unterschiedliche Zonen für einen Tag. Sehr oft bleibt er bei einer solchen Konfiguration in der Ladestation und sinniert über Zeit und Raum...


    Ciao, -MN

  • 1.  R 44411 - 25/06/2019

    Priorität:


    Dringend Wichtig Information

    Veröffentlichung: 25/06/2019

    Software Update:

    • Veränderter Schwellenwert, um die GSM Funktion im Connect Modul zu aktivieren. Diese Version sollte verwendet werden, wenn der Roboter in bestimmten Bereichen Probleme mit der GSM Verbindung hat.
    • Beim L350 wird während er dem Begrenzungskabel entlang fährt der Stoßsensor vorne deaktiviert. Verwnden Sie diese Verion, wenn der Roboter sehr oft irrtümlich ein Hindernis erkennt, während er dem Begrenzungskabel folgt.
    • Während der Roboter in Border Cut fährt, startet er das Mähwerk wieder, sobald der AirMarker nicht mehr erkannt wird.

    Wiper geschädigter mit einem

    Ciiky Xh My 17 7030 ELO

    Ciiky XH My 14-16 5030 ELO


    Gforce 600 im Anfangsstadium

  • Nächstes Problem:



    die Ersatzakkus von Amazon (6.9Ah) zicken gegenüber den originalen Akkus (7.2Ah) - der Roboter lädt die ganze Nacht hindurch über 12 Stunden und versucht, noch ein wenig Kapazität in die Akkus zu pressen.


    Kennt jemand eine Möglichkeit, die Akkukapazität auf 6.9Ah (das hatten die älteren originalen Akkus auch) umzustellen bzw. das Batterielademanagement zu konfigurieren?


    Danke, -MN

  • Cool, dass du uns von deinen Versuchen und Erfahrungen berichtest. Ich finde das sehr spannend. Ich denke nämlich auch, dass die Roboter zu viel mehr fähig wären. Und dass aus verschiedensten Gründen (Marketing, Lebensdauer, Garantieansprüche etc.) diese Möglichkeiten nicht angeboten werden.


    Ich erlaube mir deshalb ein paar Kommentare zu deinen Ausführungen zu geben.


    Meines Erachtens steckt das ganze Batterielademanagement nur im Netzteil und in den Batterien selbst. Das ist zumindest bei den L30, L75/85, L200 so, welche ein AM2000 Motherboard haben. Du hast ein AM4000 Motherboard, das ich nicht kenne. Ich vermute aber stark, dass es auch da so ist (bitte um Korrektur, wenn jemand weiss, dass das nicht so ist).

    Das heisst, du kannst da nichts konfigurieren und der Roboter misst nur die Spannung der Batterie. Von der Spannung her entscheidet er, ob die Batterie voll ist (>29.0V) und er losfahren kann oder ob er noch weiter lädt.


    Das Ganze gilt im gleichen Sinne auch für die Rückkehr des Roboters in die Station. Normalerweise ist auch da nur die Batteriespannung für den Rückkehrzeitpunkt verantwortlich. Wenn die Batterie bald leer ist und ein Spannungsgrenze unterschritten wird, dann geht der Roboter zurück. Die Spannungsgrenze kann im Service Menu beim Punkt "Border length" zwischen "standard" (ca. 24.5V) und "long" (höhere Spannung ... wäre interessant die genauen Spannungen zu kennen) eingestellt werden (durch den Fachmann).

    Natürlich kann auch Regen oder das Ende der Arbeitszeit eine Rückkehr auslösen und bei deinem Modell gibt es zusätzlich noch den ÖKO-Modus pro Bereich (frühzeitige Rückkehr, wenn der Sensor den bereits gemähten Rasen erkennt).

    Als letzten Rückkehrgrund sehe ich bei einem meiner Roboter auch die softwarebasierte Beschränkung der Arbeitszeit pro Tag. Mein L75 Deluxe (2017/05/22, r34765) geht mit einem 6 Ah Akku (original wäre 2.3 Ah) nach ca. 2:45h zurück zur Ladestation, weil die Batterie leer ist. Er lädt dann voll und bei der 2. Ausfahrt des Tages geht er nur noch etwa 20 min an die Arbeit, dann ist schon wieder Schluss für den Tag, obwohl die Batteriespannung noch gut ist, es nicht regnet und das Zeitfenster noch länger ist. Wenn ich dann den Roboter aus- und einschalte, geht er an diesem Tag nochmals für bis zu 3h raus (z.B. nach den Ferien sehr hilfreich).


    Du hast üblicherweise beim L250 Elite das Mean Well ELG-150-30ZCTE, 29.4 V, 5.0 A Netzteil, damit hat er für einen original 7.5Ah Akku schon 2.5 h Ladezeit gemäss Handbuch. Bei deinen 2 Akkus wird es also mindestens 5h sein, eher sogar 6-7 h. Sonst müsstest du ein stärkeres Netzteil besorgen, z.B. das 29.4 V, 12.5 A Netzteil, wie es im L250i Elite S+ (8250ES0) mit zwei 7.5Ah Batterien verwendet wird. Dann wäre schnelleres Laden möglich.

    Beim Laden über die Nacht werden die Batterien noch etwas höher auf ca. 29.2 V geladen. Diese Maximalspannung ist nur vom BMS (Batterie Management System – Platine im Akku) abhängig.


    Wenn du Probleme bei den Akkus oder beim Laden vermutest, müsstest du mal die Spannung der Batterien und/oder allenfalls an den Kontakten messen. Ab etwa 29.0 V Batteriespannung fährt der Roboter los. Oder du hängst mal je eine Batterie ab und beobachtest das Verhalten dann.


    Wenn du mehrere Mähzonen an einem Tag erzwingen willst, muss er zusätzliche Rückfahrten in die Station machen und das geht dann zumindest beim L75 nur über mehrere Mähzeiten pro Tag. Aber auch dann wird er in der Station zuerst die Batterie vollladen und sich erst danach wieder an die Arbeit machen. Der Entschied wohin er fährt, ist mit den angegebenen Parametern (Prozent oder Quadratmeter, Zonen pro Arbeitszeit) reiner Zufall, das heisst, dass er z.B. auch 3x nacheinander die kleinste Zone anfahren kann.


    Nimmt mich Wunder, wo du einverstanden bist und noch mehr wo du (oder andere) anderer Meinung bist und wie deine Erfahrungen und Interpretationen sind.

    Gruss 014356


    :004:

    Agro R800Li (~Ambrogio L75, 075DE1, 2013), Fw. 5085EV0, 2018/06/08, r40300, mit Robotan Steuerung Original 8)

    Ambrogio L75 Deluxe "Roth" (075DE0, 2013), Fw. 5085DE0, 2017/05/22, r34765, im Moment ohne Robotan Steuerung <X

    Ambrogio L75 Deluxe "Forrer" (075DE0, 2013), Fw. 5085DE0, 2017/05/22, r34765, mit Robotan Steuerung Selbstbau :evil:

  • Uns wurde gesagt das der Teufel im Bootloader sitzen soll.

    Man kann ein Board für einen Robi bekommen der mit einem Akku als auch mit 3 Akku´s läuft.

    Ein neues Board wird bei der Auslieferung dementsprechend geflasht, sonst könnte man sich ja günstig einen Roboter mit einem Akku kaufen und dann 2 Nachrüsten.

    Damit das nicht passieren kann, wird so vorgegangen.


    ...so auf einer Schulung von Wiper

    Wiper geschädigter mit einem

    Ciiky Xh My 17 7030 ELO

    Ciiky XH My 14-16 5030 ELO


    Gforce 600 im Anfangsstadium

  • Was mich noch interessiert: würde eine Aufrüstung auf 2 Akkus auch klappen, wenn man zum sereinmässigen 7,2er noch einen gleichen hinzu gesellt hätte, oder müssen es zwei 6,9er sein?


    Zum Hintergrund: Ich habe einen L200 mt 2 x 6,9 ah. Die Akkus kommen so ganz langsam in die Jahre und ich werde die früher oder später austauschen müssen. Hier bieten sich Angebote an, die nur die Zellen auswechseln. Und man kann dann pro Akku mehr als 6,9er reinpacken, ich glaube, es waren um die 9ah. Nur wenn ich das mache, erkennt der Roboter noch, dass er zwei Akkus hat?

    Oder wäre der einzelne 9ah nicht auch vorzuziehen? Bei mir fährt er mit zwei Akkus locker 8h, hier reichen drei Tage in der Woche.

  • Uns wurde gesagt das der Teufel im Bootloader sitzen soll.

    Man kann ein Board für einen Robi bekommen der mit einem Akku als auch mit 3 Akku´s läuft.

    Ein neues Board wird bei der Auslieferung dementsprechend geflasht, sonst könnte man sich ja günstig einen Roboter mit einem Akku kaufen und dann 2 Nachrüsten.

    Welches Betriebssystem läuft eigentlich auf dem Ding?


    Wenn es ein Linux ist, sollte sich doch ein Firmware-Update leicht auseinandernehmen und anpassen lassen...


    Danke, -MN

  • Gute frage

    ein leeres board kann nur der Vertrieb beschreiben, sprich den Bootloader aufspielen, zumindest zur Zeit.

    pasted-from-clipboard.png


    Hier ein Screenshot vom Programm , Einen Schritt weiter wird ein Schlüssel angefragt den man aber nicht bekommt.

    Wiper geschädigter mit einem

    Ciiky Xh My 17 7030 ELO

    Ciiky XH My 14-16 5030 ELO


    Gforce 600 im Anfangsstadium

  • Wenn die Android App ein Firmware-Update herunterlädt, muß dieses ja auf dem Handy gespeichert sein.


    Damit müsste sich doch eine erste Analyse durchführen lassen - hat jemand einen Ambrogio, der auf ein Update wartet?


    Bei Android läßt sich übrigens auch sehr einfach die gesamte Bluetooth-Kommunikation abspeichern und später mit Wireshark analysieren. Damit sollte es möglich sein, die Kommunikation zwischen Android App und Robi zu analysieren. Hat das schon mal jemand versucht?


    Danke, -MN

  • Was mich noch interessiert: würde eine Aufrüstung auf 2 Akkus auch klappen, wenn man zum serienmässigen 7,2er noch einen gleichen hinzu gesellt hätte, oder müssen es zwei 6,9er sein?

    Du kannst da ziemlich alles reintun, was Li-Ion Akku mit 7 seriellen Zellen (Nominal 25.2V, Ladespannung 29.3V) sind. Der Roboter kann vom Akku oder eben den Akkus nur die am Motherboard ankommende Spannung messen und entscheidet daraus, ob er rausfährt (voll, >29V), nach Hause geht (leer, <24.5V) oder weitermäht/weiterlädt (irgendwas zwischendurch).

    Man sollte aber nur ähnliche Akkus von Grösse, Alter und Ladungszustand (voll/leer) zusammenhängen.

    Ob das 1 oder 2 Akkus sind spielt keine grosse Rolle, am Schluss muss er einfach fertig werden mit mähen. Bei sehr grossen/schweren Akkus und steilem Gelände spielt die Gewichtsverteilung auf den Rädern noch ein wenig ein Rolle. Bei Low Cost Akkus wird meist mit der Kapazität (x Ah) und der Lebensdauer geschummelt.



    Firmware:

    (teilweise nur Vermutungen meinerseits)


    Die AM2000 Motherboards (L30, L75, L85, L200, L250) haben einen H8S/2144A Prozessor verbaut

    Gute Übersicht: https://www.renesas.com/br/en/…2100/h8s2148-h8s2144.html

    Datenblatt: http://www.farnell.com/datasheets/101891.pdf


    Alte Firmware Files (vor 2010) findet man bei Ambrogio hier: ftp://ftp.centrosistemi.it/Public/Etflash3/Ambrogio

    Dort sind es die *.a37 Files. Die aktuellen FW Files werden von der App immer noch auf einem FTP Server bei Zucchetti abgeholt (PM mit genauerem dazu), es sind immer noch *.a37 Dateien. Die *.hex Dateien sind für das neuere AM4000 Board (L35, L300?, L400?, NEXTline 4.0?), das hat einen anderen/neueren Prozessor.


    Eine Entwicklungsumgebungen für den H8S Prozessor ist hier:

    F-ZTAT Microcomputer On-board Writing Program is flash MCU on-board programming software for SuperH, H8S, H8 embedded Systems:

    https://www.renesas.com/br/en/…oard-writing-program.html

    Simulator Debugger for H8SX, H8S, and H8 Families for High-performance Embedded Workshop:

    https://www.renesas.com/sg/en/…families.html#productInfo

    Ich wollte mich da mal noch durchkämpfen und diese Umgebungen installieren, da ich aber von Programmieren wenig Ahnung habe, konnte ich mich noch nie dazu motivieren.

    freetz hat jemanden mit Assembler Kenntnissen gesucht und hat sich da auch gewisses Wissen angeeignet

    … wenn es noch jemanden geben sollte, der sich halbwegs mit Assemblerprogrammierung (hier: Renesas H8) auskennt, wäre das eine große Hilfe.

    Da gibt es schon noch ein Tummelfeld für jemanden, der daran Spass hat.

    Gruss 014356


    :004:

    Agro R800Li (~Ambrogio L75, 075DE1, 2013), Fw. 5085EV0, 2018/06/08, r40300, mit Robotan Steuerung Original 8)

    Ambrogio L75 Deluxe "Roth" (075DE0, 2013), Fw. 5085DE0, 2017/05/22, r34765, im Moment ohne Robotan Steuerung <X

    Ambrogio L75 Deluxe "Forrer" (075DE0, 2013), Fw. 5085DE0, 2017/05/22, r34765, mit Robotan Steuerung Selbstbau :evil:

  • Alles sehr gut beschrieben.

    Dazu meine Erfahrungen mit dem Batteriemanagement meines Roboters.

    Ich habe den Stiga 550 SG im Originalzustand.

    Voll geladen mäht er zwischen 7-8 Stunden durch.

    Programmiert man ihn zum Beispiel auf eine Mähzeit von 9 Uhr bis 19 Uhr, dann fährt er nach ca. 7 Stunden in die Ladestation.

    Also gegen 16 Uhr.

    Er bleibt aber dort nur so lange, bis er genug Strom hat um bis 19 Uhr noch relativ viel Zeit beim Mähen zu verbringen.

    Ladezeit in dem Fall knapp 40 Minuten, dann mäht er bis 19 Uhr und fährt wieder rein.

    Das deutet doch wohl daraufhin, das das Lademanagement nicht nur in den Batterien oder im Ladegerät alleine verwaltet wird, denn woher sollten diese Teile wissen das er noch bis 19 Uhr mähen soll ?

    Dann noch eine Farge dazu:

    """"""""""Wenn du mehrere Mähzonen an einem Tag erzwingen willst, muss er zusätzliche Rückfahrten in die Station machen und das geht dann zumindest beim L75 nur über mehrere Mähzeiten pro Tag. """""""""""

    Wenn ich verschieden Zonen in einem Mähzyklus anfahren will, muss ich dann für jede Zone eine neue Startzeit setzen ?

    Laut Bedienungsanleitung wäre das nicht so.

    Da stehts als Beispiel so: Zeit von 8 Uhr bis 12 Uhr. Zone A1, A2, A3 .

    Wenn das so wäre-----woher weiß der Mäher dann wo die verschiedenen Zonen sind ?

  • Da stehts als Beispiel so: Zeit von 8 Uhr bis 12 Uhr. Zone A1, A2, A3 .

    Wenn das so wäre-----woher weiß der Mäher dann wo die verschiedenen Zonen sind ?


    Hatte ich mal konfiguriert, hat mir nicht gefallen. Der Mäher ist häufig in Zonen gefahren, die er statisch seltener besuchte (weil kleiner). Daher wäre meine Vermutung, er versucht die Zonen statistisch gleich häufig zu mähen - das macht aber bei einer großen Zone und mehreren kleinen nicht wirklich Sinn...


    Ciao, -MN

  • Du hast üblicherweise beim L250 Elite das Mean Well ELG-150-30ZCTE, 29.4 V, 5.0 A Netzteil, damit hat er für einen original 7.5Ah Akku schon 2.5 h Ladezeit gemäss Handbuch. Bei deinen 2 Akkus wird es also mindestens 5h sein, eher sogar 6-7 h. Sonst müsstest du ein stärkeres Netzteil besorgen, z.B. das 29.4 V, 12.5 A Netzteil, wie es im L250i Elite S+ (8250ES0) mit zwei 7.5Ah Batterien verwendet wird. Dann wäre schnelleres Laden möglich.

    Jetzt wird es für mich recht interessant...


    Das Meanwell ELG-150 ist laut https://www.meanwell.com/Upload/PDF/ELG-150/ELG-150-SPEC.PDF ein LED-Trafo, den es in zwei Variationen (Konstant-Spannung und Konstant-Strom) gibt. Eine 30V-Variante wird nicht aufgeführt. Eine ZCTE ebenfalls nicht.


    Ich hab bei meinem Netzteil mal das Kabel zur Ladestation aufgetrennt - dort sind nur 3 Kabel verbaut. Das passt zu keinem der Diagramme.


    Laut https://www.ambrogiorobot.com/…V_L4.0BASIC_V1_.1_DE_.pdf Seite 6 gibt es ein ELG-240-30ZCTE-Netzteil, daß 8A Ladestrom liefert (statt 5A wie das -150). Wie kommst Du auf die 12.5A? Ich finde mit dem Suchbegriff S8250ES0 keinen Treffer bei Google...


    Danke, -MN

  • Also mein Stiga 550SG sollte doch ( fast ) Baugleich mit dem L250 Elite sein.
    Bei mir ist ein 12,5 Ampere Netzgerät dabei.
    Bezeichnung: Mean Well PB-360P-24KF

    Files

    • ladegerät.jpg

      (2.73 MB, downloaded 18 times, last: )