Problemstellen

  • Hallo zusammen


    mein Roboter fährt nun schon eine Weile. Kantensteine rundum 12cm. Abstand BK zu den Kantensteinen ist rundum 13cm außer an den eingezeichneten Stellen.

    Inbetriebgenommen habe ich den M700 mit der v3.08. Dabei ist folgende Problemstelle entstanden:


    problem1.jpg


    Er blieb niemals hängen aber wie ihr seht hat er sich ordentlich eingegraben. Anfangsdachte ich noch es wäre vll zu uneben, also habe ich gesandet. Ich habe das dann aber beobachtet und hatte festgestellt, dass der Abstand rechts zwischen dem Tor und dem Rasen so gering war, dass er sich beim drehen durch Anstoßen des Gehäuses an der Wand nach hinten gedrückt hat. Die Stelle links ähnlich, nur dass er zwischen der Lücke zwischen Der Terasse und dem Zaun anstößt. In meinen Augen hat er sich immer in die falsche Richtung gedreht (großer Winkel statt kurzer). Klar: Theoretisch müsste ich laut Anleitung mehr Abstand lassen mit mind. 21cm dachte ich aber ich hätte genug. Er mäht aber auch mit diesem geringen Abstand rechts das Grasbüschel nicht weg. Auch nicht beim Kantenmähen.


    Hier die Stelle im Überblick:


    IMG_20200629_105127_resized_20200629_111849985.jpg


    Die Erde habe ich nun aufgefüllt, damit die Löcher wieder gefüllt sind, sonst bleibt er wegen Aufsetzen hängen.

    Nach Lesen im Forum habe ich viel von "falscher Drehung am BK" gelesen und dachte dann vll. liegt es daran. Also bin ich zurück auf v2.87

    Gefühlt ist das "wühlen" an dieser Stelle nun geringer geworden (ich muss wohl noch nachsähen) aber dafür habe ich nun eine neue Problemstelle:


    IMG_20200629_105132_resized_20200629_111848831.jpg

    IMG_20200629_105138_resized_20200629_111911240.jpg


    Hier ist er regelmäßig außerhalb des BK. Einmal stand er sogar mit den Hinterrädern auf der Terasse:


    problem2.jpg


    Gelernt habe ich, dass die Firmware Version nur so gut ist wie die Gegebenheiten. Würde es in meinem Fall nur helfen das BK weiter wegzulegen, wohlwissend, dass dann noch weniger gemäht wird?

    Bei Kantenfahrten habe ich keinerlei Probleme. Welche Optimierungstips habt ihr für mich? Gerne auch gleichzeitig Tips wie ich die nicht gemähten Stellen ggf. doch gemäht bekomme primär aber wäre es mir wichtig, dass er sich nicht außerhalb des Kabels befindet oder eingräbt.


    Danke und viele Grüße

    Christopher


    PS: Ja, mein Rasen braucht Wasser. Teilweise ist er bis zur Unkenntlichkeit verbrannt.

  • Wenn du die letzten Posts im Firmwarethread 3.13 verfolgst haben sie da die gleichen Probleme. Positec schlägt momentan 2x45 Grad in der Ecke vor🤷🏻‍♂️
    achja, lt. Anleitung sind es vor Hindernissen 26cm Abstand und nicht mindestens 21cm...😄😉

    ...ausm schönen Schwarzwald :)

  • Wenn du die letzten Posts im Firmwarethread 3.13 verfolgst haben sie da die gleichen Probleme. Positec schlägt momentan 2x45 Grad in der Ecke vor🤷🏻‍♂️
    achja, lt. Anleitung sind es vor Hindernissen 26cm Abstand und nicht mindestens 21cm...😄😉

    Weiß ich (siehe oben) ;) nur hab ich mich wohl zu sehr durch die ganzen "Optimierungs Threads" gelesen und es probiert. Fraglich ob die Probleme mit 26cm weg wären. Ich bin ja nur in der Ecke näher dran. Nach der Ecke gehe ich recht schnell wieder auf 25cm. Beim Eingraben fährt er an diese Stelle schräg ran, also nicht wie beim Kantenschnitt direkt auf die Ecke drauf. Die v3.13 hab ich auf Grund der Posts noch gar nicht ausprobiert. Mit der 2.87 sollten diese Probleme ja noch nicht existieren, deshalb bin ich mittels Recoveryfile runter.

    Mit 2x45° werden aber die Ecken ja in keinem Fall mehr gemäht. Dann wäre es ja fast besser in diesen Teil noch Pflastersteine zu legen.


    Bei der Zone, in der er sich nun rausdreht sollte er dahinter eigentlich genug Platz haben. Ist ebenerdig zum Rasen und den Kantensteinen.

  • Hier ist er regelmäßig außerhalb des BK. Einmal stand er sogar mit den Hinterrädern auf der Terasse:

    Hallo,


    du musst dir das Log dazu anschauen, es kann gut sein das er mit dem Vorderrad hängen bleibt und der Mäher sich mit seinen Sonderregeln zu befreien versucht es ihm aber nicht gelingt.

    Der Primäre Fehler wäre dann nicht das BK sonder das "festhängen" des Vorderrades ...

  • Done:


    #01994 - 29/06/2020 10:48:41 - !ERROR! outside wire timeout


    #01995 - 29/06/2020 10:48:35 - [LCM] - Turning right 15°


    #01996 - 29/06/2020 10:48:34 - [LCM] - Going backward 200mm


    #01997 - 29/06/2020 10:48:34 - [LCM] - TRAPPED! drive wheel src


    #01998 - 29/06/2020 10:48:26 - [LCM] - Turning left 53°


    #01999 - 29/06/2020 10:48:26 - [Grass cut] wire met, turning: left 53deg normalMode

    Log im Anhang:

    LOG_WR142E_20200629_#1.txt

  • TRAPPED ... ab da gelten "Sonderregeln" die der Mäher abarbeitet um sich zu befreien ...

    ok, aber wieso? Da ist keine unebene Stelle. Das Vorderrad kann auch nicht auf die Terasse fahren, dafür ist der Absatz zu hoch.

    Sagen wir er fährt Parallel zur Hecke auf die Terasse zu, dann würde er auf das BK stoßen und in beide Richtungen eigentlich das BK finden. Würde er hier die angegebenen 53° nach links drehen wäre da das BK.


    Sagen wir er fährt parallen zur Terasse Richtung Ecke, dann würde er auf die Spitze des BK zufahren. Dreht er sich jetzt die 53° nach links ist ggf. neben der Spitze schon außerhalb des BK aber er würde nicht festhängen im Sinne von etwas blockiert. Er wäre auch nur mit dem vorderen Teil "außerhalb des BK". Der Großteil des Mähers wäre drin. Hier zeigt er laut LOG dann "Trapped" an. Da kann er aber nicht "hängen". Da ist nichts (siehe Foto). Setzt er nun zurück und dreht dann nach rechts, wie im Log steht, würde er ggf. etwas an der Terasse anstoßen. Ist das "Trapped"?

    Mit der v3.08 war das für ihn kein Problem. Mit der v2.87 schon.

    Dafür ist die erste Problemstelle mit v3.08 besser. Soll ich zurück in die Zukunft? Wie entschärfe ich dann die andere Stelle?

  • Sagen wir er fährt parallen zur Terasse Richtung Ecke,

    Was wir sagen, spielt keine Rolle. Entscheidend ist, was der Robbi macht. Und da hilft alles nix, entweder stellst du dich mal eine Weile daneben, und schaust dir das an, oder du legst das Kabel so, daß der auf jeden Fall nicht hängenbleibt. Denn auch wenn es vielleicht komisch klingt, das geht. Da bleibt dann ein Stück Rasen ungemäht, so ist das halt.


    Oliver

  • würde er ggf. etwas an der Terasse anstoßen. Ist das "Trapped"?


    Ja, bei allen Bewegungen die der Mäher machen will aber nicht ausführen kann und es bemerkt ist Trapped.

    Mit der v3.08 war das für ihn kein Problem. Mit der v2.87 schon.

    Ja, leider unterscheiden sich die verschieden Firmwareversionen, besonders in der "Trapped-Fahrweise", voneinander (einer erkennt eine Verbesserung - der andere wieder eine Verschlechterung ... zum Schluss zählt die Anzahl der gemeldeten User bei denen es nicht funktioniert gegenüber der verkauften Mäher und die User die sich nicht melden.)

  • Was wir sagen, spielt keine Rolle. Entscheidend ist, was der Robbi macht. Und da hilft alles nix, entweder stellst du dich mal eine Weile daneben, und schaust dir das an, oder du legst das Kabel so, daß der auf jeden Fall nicht hängenbleibt. Denn auch wenn es vielleicht komisch klingt, das geht. Da bleibt dann ein Stück Rasen ungemäht, so ist das halt.


    Oliver

    Entschuldige bitte, dass ich versuche Ideen zu sammeln. Die Erfahrung fleißiger Nutzer zeigt manchmal doch Ideen, die auch ohne stundenlanges Beobachten zum Ziel oder zumindest zur Reproduktion führen.

    Ich habe mich natürlich schon in der Beobachtung versucht. Leider ist es zu dem Zeitpunkt nicht aufgetreten.

    Jedesmal wenn es auftritt habe ich aber leider nicht hingesehen.

    Weiterhin habe ich den Roboter nun auch nochmal mehrfach dort hingesetzt und aus allen erdenklichen Positionen auf diese Ecke zufahren lassen. In keinem dieser bestimmt 20 Versuche hat er sich auch nur einmal festgefahren.


    Ja, bei allen Bewegungen die der Mäher machen will aber nicht ausführen kann und es bemerkt ist Trapped.

    ...

    Danke für die Information. Das hilft beim Verständnis. Bei meinen Reproduktionsversuchen stößt er tatsächlich beim Drehen teilweise gegen die Terasse. Bei einem Mal hat das dazu geführt dass er zurückgesetzt hat. Allerdings hat er sich durch die Drehung dort nicht festgefahren.

  • Entschuldige bitte, dass ich versuche Ideen zu sammeln. Die Erfahrung fleißiger Nutzer zeigt manchmal doch Ideen, die auch ohne stundenlanges Beobachten zum Ziel oder zumindest zur Reproduktion führen.

    Die wurden schon genannt: Kabel nach Anleitung verlegen.


    Oliver

  • Ich wollte nur noch ergänzen: An dieser Stelle gibt es folgende Abweichung zur Anleitung:


    Abstand des BK zur Terasse: 25cm statt 26cm

    Statt einer 90° Innenecke bin ich weiter bis zur Begrenzung weil es dahinter befahrbar ist. Gehe danach aber mittels Dreieck schnell zurück auf 25cm.

    Dieser Fall ist so aber in der Anleitung gar nicht abgebildet.


    Theoretisch reichen an dieser Stelle laut Anleitung 10cm Abstand durch die mögliche Überfahrung. Durch die Kantensteine hab ich 12. Mir fehlt nach rechts zur Terasse also genau 1cm bis zur nach Anleitung korrekten Verlegung.

  • Was ich meine hier nochmal dargestellt:


    ueberfahrbar_nicht_ueberfahrbar.jpg


    Der blaue Bereich ist überfahrbar. Das ist eine Ebene. Da gibt es auch keinerlei Spuren vom Roboter.

    Der gelbe Bereich ist natürlich nicht überfahrbar. Da habe ich einen Abstand von 25cm zur Terasse (12cm Kantenstein plus 13cm Abstand) also genau 1cm weniger als in der Anleitung.

    An der pink markierten Ecke bin ich nach rechts zu Terasse diesen 1cm zu nah an der Terasse aber in Richtung blaue Markierung anleitungskonform was den Abstand betrifft. Lediglich die Dreiecksmethode habe ich mir hier aus dem Forum gezogen. Theoretisch könnte ich da in exakt 90° (nach Anleitung) weiter gehen und hätte alle Abstände (10cm) eingehalten, ich gehe aber früh wieder auf den notwendigen Abstand um zur Hecke (links im Bild) einen größeren Abstand zu haben.

    Die Situation (Kombination gelber und blauer Bereich) ist so in der Anleitung nicht beschrieben. Ob sich die Situation verändern würde, wenn ich den einen cm mehr hinzunehme ist fraglich aber das kann ich gerne ausprobieren.

    Wie aber schon gesagt war diese Stelle mit der v3.08 kein Problem.


    Wenn ich also nun nach Anleitung vorgehen soll, dann beschreibe mir bitte wie das in diesem Fall aussieht.

    An der blauen Stelle bedeutet "nach Anleitung" nicht 26cm Abstand. Vermutlich ist aber das deine Empfehlung?


    https://worx-europe.com/wp-con…leitung_WR142E-WR143E.pdf


    Anleitung_s13.png


    Anleitung_s14.png

  • Lediglich die Dreiecksmethode habe ich mir hier aus dem Forum gezogen.


    Ich vermute stark, daß dieses Dreieck diesen "Unfall" bewirkt. Ich bin fast überzeugt, daß dies bei der Kantenfahrt passiert ist.

    Er fährt in das Dreieck rein, wendet und fährt dabei zurück - je nach Winkel - kann er an die Terasse anstoßen oder nicht und versucht sich dann zu befreien.

    Dadurch hüpft er letztendlich auf die Terasse.. So meine Vermutung .............

  • Versuche es mal ohne dieses Dreieck --- Ränder nacharbeiten ist ja immer vorhanden ;(

  • Das mit dem Dreieck hast du falsch verstanden, das gilt nur für Aussenecken („rechts abbiegen“). Daher kommt dann wohl auch das Problem. Mit dem Dreieck zwingst du ihn, auf dem Kabel rückwärts zu fahren, dabei fährt der dann gegen die Terasse, und das Drama beginnt. Für den Fall reichen die 26cm Abstand nicht aus.


    Leg in der Ecke zunächst mal 2x45 Grad. Wenn das ein paar Tage problemlos funktioniert hat, dann kannst du entweder die Schräge verkleinern, oder auch mal einen 90 Grad Winkel probieren.


    Oberstes Ziel ist immer, daß der Robbi störungsfrei fährt. Erst wenn er das tut, kannst du versuchen, die Ecken so zu optimieren, daß alles gemäht wird.


    Ansonsten ist die Sache mit dem Abstand einfach: Das Kabel muß 26 cm von allem weg bleiben, was den Robbi stören könnte. Wenn es aber weit und breit nichts gibt, was ihn stören könnte, dann empfiehlt die Anleitung 10cm.

    Oliver


    P.S. Harry war schneller ;)

    Edited once, last by OliverSo ().

  • Das mit dem Dreieck hast du falsch verstanden, das gilt nur für Aussenecken („rechts abbiegen“).

    Oh man. Hatte mir das beim ersten Bild schon gedacht. Wollte much aber lieber zurück halten da ich meinen m500 erst seit gestern habe. :/

  • Das mit dem Dreieck hast du falsch verstanden, das gilt nur für Aussenecken („rechts abbiegen“).

    Ich glaube nicht daß er das falsch verstanden hat, da bei dieser Anordnung bis in die Ecke gemäht wird. Nur die Terasse hatte er dabei nicht im Auge......