Hom-Bot 3.0 Hacking

  • Hello Alles,


    ik heb een vraag. Ik probeer het WiFi-hack te doen. Maar ik wil mijn LG HomBot terugzetten met een back-up.
    Dus ik heb een pakket met de backup script (backup.tar en alle andere bestanden)
    Hoe kan ik dit doen? Ik kan dit niet vinden op dit forum. (misschien een FAQ-ding?)


    Als iemand het moet weten. het is de LG VR8604OB met de backup.tar versie 17341

  • * I see that i have written this in Dutch..


    Hello All,


    I have got an question, i have tried to do the WiFi-hack, with a downgrade. But I want to reverse to my original firmware. I have the original back up with the backup tool. (Backup.tar and the other files that were made.) Only i can't find out on this forum (Mainly because my german is not so good.) Can you help me?


    For your information. It is a LG VR8606OB with original firmware 17341. Thanks you?

  • Hi, ich habe gerade bei meinem VRD710RRC den WLAN Hack Installiert es hat zuerst geklappt nach paar min war die WLAN Verbindung weg wollte daher dann eine feste IP einstellen was jedoch nichts gebracht hat der BOT verbindet sich mit dem WLAN garnicht mehr egal wie ich die Einstellung einspiele.
    Woran kann das liegen dass nun überhaupt kein WLAN geht? Wenn ich den Bot starte dann blinkt der WLAN Stick mal und mal nicht bleibt also komplett aus.


    und ich den Hack Installiert habe funst die Fernbedienung nicht mehr komplett hat noch wer das "problem"?
    MfG

  • Hi there!


    I want to share my story with lg vr6270lvm. I've bought it in the end of 2013 right from S.Korea, upon arriving I tried to update it to new Firmware and it failed. So, after a purchase it became a brick without even first run. So, it took me 2 week to restore to working state (thanks for help of this forum and Russian forum), during that period I found that two mtd blocks are dead and my robot operates now with usb stick, which holds the whole system and mount it on system startup. Also I've brute-forced root password which I shared with community on this forum.


    There was one bug, that flash stick was on fat32, and there were some difficulties with saving files on the fly and I was going to update the robot to the last Firmware but there were no way of doing it. So, I decided to connect a usb hub, which holds usb stick and usb-ethernet adapter to be able to connect to the robot and perform an update. And I encounter a problem that busybox of the device and a kernel was really aged and I wasn't able to connect to the device via usb-ethernet adapter. It took me about two months to cross-compile drivers for the devices (I wanna thank the community for cross-compile toolchain) and finally I was able to connect to device by ssh, I've recompiled dropbear, ssh, busybox, added a bunch of drivers for ext4 support and performed system update on the devices via chroot.


    So, for those, whose robot is not working, you can download dd_image and flash it to flash-stick, then insert to robot's usb port and it'll be alive again.
    For those, who want to compile drivers and any stuff for it, I've attached a virtualbox image with installed cross-compile toolchain.
    Also attaching drivers, utils.


    I've done it two years ago, and don't remember every aspects and details, so explore and don't hesitate to contact.
    PS: I'm from Russia, sound files on device are in Russian ))


    Here is a link for download https://drive.google.com/drive…dLXQS7sIy6wFV?usp=sharing

  • Hello, I'm new to the forum so thanks for accepting me in your community.
    I have a question/request. Is it possible to add a form with username/password to access the hombot control center?
    I mean, I'd like to use my hombot also for videosurveillance purpose but I don't want attackers to access the webpage without at least trying a password combination.
    Do you know if is it feasible?
    Do you know which programming language is used for the control center?
    Thanks in advance

  • It‘s not a good idea to make the hombot accessible via internet. The OS is not on a patch level needed for this. A login window will not change this.

    LG Hombot VR64703LVMB mit EDIMAX EW-7811UN

    Software : lg.srv, V2.50 compiled 13.11.2016, by fx2

  • Hallo zusammen - auf die Gefahr hin, dass ich nicht alle 140 Seiten in diesem Thread gelesen habe und ich mir sicher bin dass ich die Problematik irgendwo schon mal gelesen habe nochmal:
    Nach dem Aufspielen des Wifi-Hacks - was beim VR8600R neue Software ohne Probleme funktioniert - ist die Freude geringfügig getrübt, weil nun offenbar der Start/Pause und der On/Off Knopf der Fernbedienung nicht mehr funktioniert.
    Ich hatte bereits über dieses Phänomen bereits gelesen, was wohl nach Abziehen den Wifi-Sticks verschwindet.
    Gibt es hier ein Lösung ?
    PS: ja ich habe die Suchfunktion genutzt welche schön die Thread´s auflistet aber nicht die Beiträge ...:mad2:

  • Hallo!
    Ich habe das Problem das der LG Home Bot VRE 610 BKC in einer Endlosschleife beim Booten hängt. Hatte das WLAN-Hack installiert, was zwar funktionierte, die Fahrwege danach allerdings sehr zufällig erschienen, daher habe ich es wieder zurücksetzen wollen. Hierbei habe ich die alte Version (Ordner old) wieder per USB überspielt. Jetzt hängt der LG dauerhaft in der Bootschleife. Das Rettungsscript habe ich schon ausgeführt und eine neue Firmware 16552 aufgespielt. Dies hat zwar alles funktioniert, eine änderung hat sich allerdings nicht ergeben. Kann man den LG noch retten, oder muss ich ihn einschicken?


    Vielen Dank für die Hilfe!

  • Hi ! I've tried to find someone who own the VR8604OB since so much time that i thank i was the only one who want to hack this one. I'm french so i'm completely lost in this deutsh forum (even using google translate), can you help me to do the same handling with this robot ? I saw that we have to update with the 16552 while i'm in 19954.


    Can you confirm that it's possible to downgrade to 16552 on the 8604OB without problem on this model ? You're the only one i've found who have tried it, i hope you're still on this forum to help me

  • Hello Alain from Brittany :-)
    I succeeded to apply this wonderful hack to my VR7412RB, indeed with a 16552 based official firmware.
    I just could not live without it, it is much too useful!
    I am not sure it will apply well to your VR8604OB.
    But I can still explain you the steps to proceed, if you want.
    Cheers

  • Hello Alain from Brittany :-)
    I succeeded to apply this wonderful hack to my VR7412RB, indeed with a 16552 based official firmware.
    I just could not live without it, it is much too useful!
    I am not sure it will apply well to your VR8604OB.
    But I can still explain you the steps to proceed, if you want.
    Cheers


    Well seen, you're French too ?
    I've just read a post talking about hacking a 16552 version to a 19954 but i'm not sure i've understand what it was talking about, i dont speak german at all, Google trad is my friend for that !
    Do you think it's possible ?

  • This will help you understand the thread:
    https://translate.google.com/t…cking-Tweaking&edit-text=


    Overall, I understood that he tried to implement the hack, mixing files from both versions, with various issues because he did not want to downgrade some files as provided by the hack: dropbearmulti and rpmain.axf.


    Then, I could read another interesting thread:
    http://www.roboter-forum.com/s…-(wlan-features-unlocken)translated here for your convenience:
    https://translate.google.com/t…es-unlocken%29&edit-text=


    This one explains how he managed to install the hack on the 17341 version, by doing a full backup first and then selecting the right files from the backup and the hack.
    And he provides a rpmain_17341.axf file in his google drive.
    Maybe ask him to help you for the newer 19954 version?


    Good luck!

  • Hi everyone,


    I hope its not against the rules replying in english. I have also found a homebot and got myself the super edimax usb dongle. I have a problem with the wifi mod..... The bot does not say "start a connection over the network". I followed the exact steps without the fixed ip. After it started up it says just the number "3". Can anyone help a noob with probbably some silly problem :) ?? Have a nice evening.


    Greetings from John

  • Hey John,


    the voice output probably does not say the hole last number of the IP, which your DHCP gave to the bots adapter.
    Watch out for active IPs in your Network on your Router to find out or just take a minute to preset the IP in the config file.


    GreetZ, DerGecko

    Indego S+ 350 für 220m²

    Status - to be installed

  • Hi DerGecko,


    Danke fur dein bericht :)! I tryed to look for the ip and I noticed an extra IP adress pop up (192.168.178.032 ..... had to be something with 3 :p). Once I go to this adress it changes the 032 into 026 in the browser and then says page not availible. Tryed IE, Edge, Chrome as browser and all can not reach the adress. I tryed the homebot app and thank god this one works (main reson for the update). I put the adress 192.168.178.032:6260 as adress (also tryed this in the browser but without succes). I have to thank the maker of the mod for everything that works so far, AMAZING JOB !!! For the fixed IP I have a few questions .... Can I put a random availible IP adress? My code would look like this then at line 69 :


    udhcpc -i "$WIFI_DEVICE_NAME" -n -t 5 -q
    ifconfig "$WIFI_DEVICE_NAME" 192.168.178.040 up
    route add default gw 192.168.178.1
    echo "nameserver 192.168.178.1" > /usr/etc/resolv.conf


    is this ok ?


    Thank you so much for the support ^_^ !


    Greetings John

  • Hi everyone,
    My german is not that good, so I will try it in English. I have an LG vr8600RR and I tried to do the Wifi hack. When updating the vr8600RR to the version 16552, it says complete. And also when I install the Wifi hack it says complete. But when I turn the vr8600RR on, it looks like he stays booting on. And now I can't use him anymore :nonod:.


    Who could help me?


    Greetings,


    Jonathan

  • Hi
    I bought LG vr65710LVMP. How check version firmware? Working hack on my robot?
    Thanks for your answer.