Posts by Mangoheini

    Aus irgendeinem Grund gehen die E-Mail Benachrichtigungen nicht mehr bei diesem abonniertem Thema. Markiert mich gerne wenns ne Frage an mich gibt, dann krieg ich das auch mit :D


    Die Karte selbst ist ja kein Bild, daher sind alle möglichen Bildverarbeitungen damit nicht durchführbar

    Seit deine App Karten anzeigen kann, haben wir Mi Home auf keinem der Geräte mehr. Vielleicht täusche ich mich, aber in meiner Erinnerung hat Mi Home das mit der Skalierung der Karte etwas besser hinbekommen - also mit weniger Whitespace außenrum. (früher war ja eh alles besser ... 8o) Ich verspüre jetzt aber wenig Lust, Mi Home auf mein "sauberes" Robi Telefon zu packen. Könnte bitte mal jemand, der beide Apps benutzt, vergleichen, ob Mi Home und FloleVac wirklich die selben Kartenausschnitte zeigen und wo ggf. die Unterschiede liegen?


    Flole: Eine Idee hätte ich noch. Wie gibst du die Karte denn so auf dem Bildschirm aus, dass man sie zoomen und verschieben kann? Könnte man da evtl. die Zoomstufe begrenzen und das "Bild" einfach zentrieren, wenn die Karte größer wird?


    Ich stell mir das so vor, dass man einen kompletten Grundriss in der Kartenansicht so zoomt, dass alles drauf ist und dann diese Zoomstufe als Grenzwert für künftige Karten abspeichern kann. Irgend eine natürliche Grenze wirds beim raus-zoomen ja eh geben. :saint:

    So kann man es auch formulieren. Es wäre schön, wenn FloleVac den (wahrscheinlich) relevanten Bildausschnitt selbst erkennen könne. In unserem Fall befinden sich immer einige unzusammenhängende Punkte weit außerhalb von allen korrekt erkannten Flächen. Es gibt freie Bildverarbeitungsbibliotheken, die genau das erkenn können, ohne viel Ressourcen zu benötigen. Dann könnte man die Funktion einfach einschalten. Evtl. verwendet Flole sowas eh schon zur Anzeige der Karte. Leider ist der Quellcode nicht öffentlich. Deshalb frage ich hier. :-)

    Ich hätte einen Verbesserungswunsch zur Kartenansicht. In unserer Wohnung befinden sich mehrere reflektierende Gegenstände, u.A. der Fuß vom Keramik-WC, ein hochglänzender Regalsockel, der Fuß einer Stehlampe und ein metallener Abfalleimer. Diese Gegenstände sorgen beim Kartieren für strahlenförmige Artefakte, die zwar nicht bei der Navigation stören, aber dazu führen, dass die Karte unnötig verkleinert dargestellt wird.


    Beispiel: Sobald Robi im Wohnzimmer in die Nähe der Stehlampe kommt, erscheinen in der Karte Strahlen und "virtuelle" Wandpunkte, die das Wohnzimmer gespiegelt draußen im Garten abbilden. Größtenteils verschwinden diese Strahlen wieder, wenn Robi die Karte weiter aufbaut, aber einzelne Punkte dieser Strahlen bleiben stehen. Da der Effekt auf allen Seiten der Wohnung auftritt, wird der Grundriss viel zu klein dargestellt. Ohne zu zoomen ist kaum was zu erkennen.


    Ich würde mir so eine Art Filter wünschen, der diese Kartierungsartefakte ausblendet. Ideal wäre es, wenn man den Schwellwert per Schieberegler selbst einstellen könnte. Je nach Einrichtung und Grundriss tritt der Effekt vermutlich unterschiedlich stark auf, aber ich denke, dass jeder von euch weiß, was gemeint ist.


    edit: Es geht natürlich nicht um die Karte selbst sondern nur um deren Darstellung in FloleVac. Robi hat offensichtlich kein Problem mit den Artefakten. Viele sind es auch nicht. Die paar verlorenen Punkte reichen jedoch dafür, die Karte in der App auf halbe Größe zu verkleinern.


    edit2: Der selbe Effekt tritt auch beim Gen1 der Schwiegereltern auf. Dort stehen die spiegelnden Gegenstände jedoch eher an Innenwänden, weshalb die Spiegelungsartefakte keine Auswirkungen auf die Skalierung des Grundrisses in der App haben.

    Fehler ist identifiziert und wird im nächsten Release behoben sein.

    Großes Dankeschön von mir für den tollen Support!


    Ich würde mich übrigens immer noch riesig über eine A-Z Anleitung freuen, wie man den Robi rootet, Dustcloud auf einem Pi (z.B. Zero W) einrichtet und anschließend alles so mit FloleVac verheiratet, dass der Robi komplett offline läuft und man trotzdem die Karten-Funktionen nutzen kann. (Puh, komplizierter Satz)


    Links auf die entsprechenden Seiten im dustcloud-wiki, eine Anleitung für den FloleVac-Part und eine Rahmenerklärung, wie das alles in welcher Reihenfolge zusammenspielt, würden mir reichen. Es hört sich so an, als wäre meine gewünschte Konfiguration so machbar, aber sicher bin ich da nicht. Und im Dustcloud-Wiki liegen zwar viele Infos, aber keine Schritt-für-Schritt-Anleitung, die einen an die Hand nimmt. Z.B. ist mir nicht klar, wie man die Karten vom Robi in die Dustcloud und von dort in FloleVac bekommt.


    Ich traue mir die im Dustcloud Wiki beschrieben Schritte prinzipiell zu, aber ich würde das ungern anfangen, so lange es keine durchgehende Anleitung gibt. Ja, ich weiß, bin ein Angsthase. :saint:


    Wenn das jemand schonmal genau so erfolgreich eingerichtet hat, wäre es wirklich toll, wenn er seine Erfahrungen mit uns teilen könnte.


    Flole: Meinst du, die beschriebene Konfig (also kompletter Offline-Betrieb, aber mit Karten) ließe sich umsetzen?

    Huhu,

    vielen Dank für die Verbesserungen! Den Nicht-Stören Modus hatte ich wirklich vermisst. Ich habe allerdings immer noch den Effekt, den ein anderer Nutzer bereits beschrieben hat, dass auf der Statusseite neben "Betriebsstunden" der Wert in Minuten angezeigt wird - zumindest ist der angezeigte Wert mindestens das Zehnfache der realen Laufzeit. Minuten statt Stunden könnte also hinkommen. Die Anzeigen fürs Verbrauchsmaterial scheinen jedoch in der richtigen Einheit zu rechnen. Wär nett, wenn du da mal drauf gucken könntest und den Wert ggf. durch 60 teilst. Die Angabe in Stunden erscheint mir grundsätzlich sinnvoll zu sein. Der Fehler tritt unabhängig voneinander auf zwei Android Handys mit zwei verschiedenen Gen 1 Robotern auf - beide ungerootet - einer noch fast neu. Bei dem fällt der Fehler besonders auf. Der ist laut Anzeige schon mehr Stunden gelaufen als er sich in unserem Besitz befindet. ^^


    Beide Roboter laufen aktuell mit der 3357er Firmware und FloleVac habe ich eben erst auf die neuste Version aktualisiert.

    Bei mir kam auch die Meldung, aber der Download wollte nicht starten. Habs dann manuell runtergeladen und drüber installiert. So gings dann. Ich dachte, das Problem hätte mit dem (zufällig gleichzeitig laufenden) Firefox-Update zu tun gehabt, aber es scheinen ja auch andere betroffen zu sein. Ist also wohl ein Bug.

    Hallo zusammen,


    ich hatte schon Mitte Mai gefragt, ob mir jemand von euch mal eine kleine Anleitung schreiben kann, wie man Roboter, Flole-App und Dustcloud (auf Raspberry Pi) so konfigurieren kann, dass das ganze System wirklich offline läuft. Wichtig wäre mir, dass ich mit der Flole-App trotzdem Zugriff auf alle funktionen inkl. Karten habe. Leider hat mir bisher niemand geantwortet. :cryin:


    Funktioniert das überhaupt so, wie ich es mir vorstelle? :confused5:


    Das Dustcloud Wiki (https://github.com/dgiese/dustcloud/...i-Installation) ist mir bekannt. Ein (bisher ungerooteter) Roboter, Linux-Kenntnisse sowie ein Pi sind vorhanden. Ich bin nur nicht sicher, was in welcher Reihenfolge zu tun ist und ob sich mein Wunsch überhaupt umsetzen lässt. Links auf die entsprechenden Anleitungen im Dustcloud Wiki würden mir reichen. Aus den Fragen in den letzten Wochen schließe ich, dass die Kartenfunktion in Verbindung mit Dustcloud nicht ganz so trivial ist. Und das Dustcloud Wiki enthält leider keine zusammenhängende Anleitung für meine Wunsch-Konfig.


    Im Moment stecken der Robi und ein altes Handy mit Flole-App im Gast-WLAN der Fritzbox, aber die Karten (und evtl. andere Daten) laufen so ja immer noch über den Xiaomi-Server. Davon will ich gerne weg. Ich wäre wirklich dankbar für eure Hilfe. :-)


    *bump* :aureola:

    Ja das ist in der Tat korrekt. Still und heimlich hab ich letzte nacht ein Update veröffentlicht. Es sind die Wünsche von hier berücksichtigt worden: Die Barrierefreiheit in der Karte wurde eingebaut, außerdem kann nun ein eigener Server für die Maps in Kombination mit Dustcloud genutzt werden. Beim Import können nun Optional Statistiken über die Geräte einmalig an Dennis (Entwickler der Dustcloud) übermittelt werden, somit kann er wissen auf was es sich lohnt zu fokussieren und andere Informationen darüber erhalten. Dies ist Opt-In, also wer es nicht explizit während des Imports erlaubt der trägt auch nichts dazu bei. Zusätzlich ist es direkt beim Import nun möglich die Login-Daten zu speichern sodass später nur noch einmal der Server ausgewählt werden muss.


    Ich denke das Changelog ist so relativ vollständig, ich schreibe das bewusst nirgendwo auf weil es sehr viel Zeit in Anspruch nimmt und dennoch Dinge vergessen werden, oder aber es ist ein stumpfes "Fixed Bugs and improved User Experience" was auch niemandem hilft


    Verstehe ich das richtig, dass man nun mit deiner App + Dustcloud den Roboter komplett offline und ohne Xiaomi-App betreiben kann und trotzdem Zugriff auf alle Funktionen inkl. Karten hat? Das wäre in der Tat ein großer Meilenstein! :Bravo:


    Könntest du bitte eine kurze Anleitung schreiben (oder verlinken), wie sich so ein Setup (Offline-Nutzung des Robis ohne Xiaomi-App, dafür mit Dustcloud auf dem Pi und Karten in deiner App) einrichten lässt?


    Das Dustcloud Wiki (https://github.com/dgiese/dust…Raspberry-Pi-Installation) ist mir bekannt. Ein (bisher ungerooteter) Roboter, Linux-Kenntnisse sowie ein Pi sind vorhanden. Ich bin nur nicht sicher, was in welcher Reihenfolge zu tun ist und ob meine Wunschkonfig überhaupt funktioniert.


    Im Moment betreibe ich den Robi und ein altes Handy mit deiner App im Gast-WLAN der Fritzbox, aber die Karten (und evtl. andere Daten) laufen so ja wohl immer noch über den Xiaomi-Server. Davon will ich gerne weg.


    In jedem Fall vielen Dank für die Leistung! :thx:

    Den Bug habe ich *immer*, wenn ich zwischen mehreren Robbies wechsle. Nach dem Start der App habe ich immer eine korrekte Anzeige für den ersten Robbie in der Liste, wechsle ich auf den zweiten: *Immer* Fehlanzeige. Witzig ist: Wechsle ich dann nach "Karte", zeigt die App dort den Akkustand bspw. korrekt an, auf der Steuerungs-Seite nicht (Steuern und "finden" geht aber).


    Ich habe nur einen Roboter. Das kann also nicht der Grund dafür sein, dass der Powermodus und der Akkustand nicht richtig angezeigt werden.

    Hey Flole,
    vielen Dank für die coole Kartenfunktion. Läuft hier alles wie am Schnürchen. Einen (alten) Fehler hab ich aber noch. Und zwar bekomme ich den Akkustand häufig mit 0% angezeigt. Auch die momentane Leistung wird dann nicht angezeigt. Da steht dann nur "Powermodus" im Button. Die Verbindung zum Roboter steht aber. "Roboter finden" funktioniert und man kann ihn auch losschicken. Das muss also ein Bug sein. Könntest du dir das beizeiten mal angucken?
    Achja, gerade eben hatte ich das Problem auch und als ich nach 5 Minuten nochmal aufs Handy geguckt hab, war die Anzeige wieder ok ohne dass ich zwischendurch irgendwas gedrückt hätte.

    Hallo Flole. Ich wollte nur kurz mitteilen, dass bei der "Deutsch HD" Stimme ein Bug aufgetaucht ist. "Verwendung der Fernsteuerung abgeschlossen" und "Verwende Fernsteuerung" sind seit neustem vertauscht. Bei der SD-Stimme passt es noch. Ich habe auch mal die Stimme neu installiert, aber das hat leider nicht geholfen. Jetzt sehe ich im Forum, dass wohl noch anderes durcheinander geraten ist. (Wie der Spruch nach Abschluss der Reinigung mal lautete, weiß ich allerdings nicht mehr. Ist schon länger her, dass ich dabei war, während Robi seine Runden gedreht hat) ;-) Wäre schön, wenn du da bei Gelegenheit mal drüber gucken könntest, Flole! Danke für den Einsatz! :-)


    PS: Und gib bitte Bescheid, wenn die Stimme wieder "geupdatet" werden muss!

    Bei mir funktioniert die Flole App ausgesprochen gut. Ich habe nur einen kleinen Bug. Wenn ich die App aufrufe, wird der Akkustand häufig mit 0% angezeigt, obwohl der Sauger voll geladen in der Station steht. Kann den Robi auch problemlos starten, suchen usw., aber der Akkustand bleibt bei 0%. Normales Wegwischen aus dem Android-Taskmanager und "Neustarten" der App bringen nichts. Nachdem ich die App über die Android-Einstellungen hart beendet und neu gestartet habe, stimmt die Anzeige aber immer wieder. (Handy ist ein altes Nexus 4 mit LineageOS drauf, das ich zusammen mit dem Robi ins Fritzbox-Gastnetz gepackt habe)


    Danke für die Mühe, Flole!

    Hallo zusammen, hallo Flole,


    seit gestern habe ich diesen Sauger und freue mich, dass ich dank deiner App nun auch deutsche Sprachausgabe haben kann. Rein optisch gefällt mir die App auch viel besser als die von Xiaomi. Vielen Dank für den Einsatz, Flole! Habe eben die neuste App-Version installiert und noch drei kleine Fragen dazu:


    - Im Verlauf sind neben den einzelnen Saugvorgängen so rote (Lösch?-)Kreuze. Leider passiert bei mir nichts, wenn ich da drauf drücke. Ist das Absicht oder ein Bug? In der Xiaomi-App habe ich bisher allerdings auch noch keine Möglichkeit gefunden, alte Saugvorgänge zu löschen.


    - In der Zeitplanung vermisse ich Regler, um die Saugstärke für die jeweiligen Jobs einstellen zu können. In der Xiaomi-App geht das. (sogar für Jobs, die ich zuvor in der Flole-App angelegt habe) Könntest du das evtl. noch einbauen, Flole?


    - Ist es irgendwie möglich, die Karte innerhalb der Flole-App anzuzeigen oder muss ich dafür immer in die Xiaomi-App wechseln? (Ich fänd es natürlich auch toll, wenn der Sauger irgendwann ganz ohne Xiaomi-App und Cloud funktionieren könnte, aber bis dahin möchte ich zumindest möglichst wenig hin und her wechseln müssen. Die Aussagen im Forum sind diesbezüglich leider nicht ganz eindeutig. An manchen Stellen liest es sich so als könnte die Flole App die Karte irgendwie aus der laufenden Xiaomi-App rüberziehen, aber ich hab noch keine Kartenanzeige gefunden. (das Handy ist gerootet, falls das wichtig ist)


    Die App ist so schon sehr schön. Mir gefällt auch, dass sie sich ohne Playstore selbst aktualisieren kann. Den Playstore hab ich nämlich gar nicht drauf. (LineageOS ohne Google Apps)


    Einen Wunsch soll ich noch von meiner besseren Hälfte weitergeben. Wird es irgendwann möglich sein, eigene Sounds hochzuladen? Meine Frau hätte für unseren kleinen Helfer gerne Wall-E, R2D2 und/oder BB-8 Sounds. Ja, ich weiß... Total sinnfrei, aber wenn es den WAF erhöht... :cool: Die Bereitstellung fertiger Soundpakete wäre natürlich noch cooler, aber das wird lizenrechtlich wohl nicht gehen. Daher die Frage nach eigenen Sounds. Dann könnte man sich selbst sowas basteln.

    Danke für den Tipp. Es ist immer gut, Alternativen zu kennen. :-)
    Inzwischen habe ich das Display übrigens auch ohne Anleitung ab bekommen. Es hat mir einfach keine Ruhe gelassen. Ich weiß nicht, ob alle Schritte wirklich nötig sind.
    Als erstes habe ich den Bumper abgebaut. Hierzu einfach die Schrauben auf der Bumper-Unterseite lösen.
    Danach habe ich die Faceplate entfernt. Die ist nur geclipst und überm Staubbehälter eingehakt (erst rundherum alle Clips mit leichter Gewalt lösen. Der Clip vorne in der Mitte war bei mir sehr hartnäckig. Anschließend kann die Faceplate überm Staubbehälter ausgehakt werden.)
    Wenn die Faceplate ab ist, kommt man besser ans Display. Auch dieses ist nicht angeschraubt sondern nur rundherum eingeclipst. Die Clipse sitzen aber sehr stramm. Den ersten Clip in der Mitte kann man von unten mit nem Schraubendrehergriff o.Ä. herausdrücken. Danach kommt man mit den Fingern unters Display und dann muss man Mut haben. Ich hab da ewig dran rumgemacht, weil ich Angst hatte, irgendwas abzubrechen. Wusste auch nicht, ob das wirklich alles clipse sind oder auch Schrauben. Es sind aber nur Clipse.
    Ein fester Ruck und man hat das Display ab. Hab zuerst auch vom Tragegriff aus versucht, das Display hochzuhebeln. Da sind so kleine Aussparungen, wo man mit nem dünnen Schraubendreher ansetzen kann. Letztlich gings aber immer nur 5mm hoch und dann war Ende.


    Ich hoffe, das hilft irgendwem.


    Der Laden, bei dem ich mein Display bekommen hab, war übrigens www.ep-mediastore-ab.de. Die haben eine riesige Auswahl an Roomba-Teilen, aber die Preise sind teilweise gesalzen. Ich bin trotzdem froh, dass ich unseren Robi wieder schick machen konnte. Hätte gedacht, dass man solche Teile gegen kleines Geld auch direkt von iRobot">">"> bekommt, aber Fehlanzeige.


    edit: Das soll keine Schleichwerbung sein. Ich habe mit dem Laden auch nichts zu tun. Das war aber auch nach langer Internet-Recherche die Einzige Bezugsquelle für diese Teile, die ich gefunden habe. :-)

    Hallo zusammen,
    seit etwa einem halben Jahr zieht ein Roomba 880 bei uns zu Hause seine Bahnen und wir sind nach wie vor von der Reinigungsleistung begeistert. Leider hat sich unser Robi vor ein paar Wochen ganz blöd unter einem scharfkantigen Heizkörper festgefahren und beim Versuch, sich zu befreien sein komplettes Bedienfeld zerkratzt. Das ist zwar nur ein optischer Makel, aber es sieht schon _sehr_ hässlich aus. Der Robi passte nur deshalb knapp unter den Heizkörper, weil der Teppich, der da sonst liegt, in der Reinigung war. Alles sehr ärgerlich.


    Im Prinzip ist unser Robi für uns ein Arbeitsgerät. Der darf also auch Schrammen haben, aber jetzt sieht er so aus, als hätte ihn jemand mit einem Messer kreuz und quer in kleine Stückchen schneiden wollen. :cryin:


    Eine Anfrage bei iRobot">">"> ergab, dass es das Bedienteil nicht als Ersatzteil zu bestellen gibt. Glücklicherweise habe ich im Netz einen Shop gefunden, der quasi sämtliche Roomba-Einzelteile anbietet - größtenteils neu, teilweise auch gebraucht. Nun hab ich hier ein neues Bedienteil liegen - also nur die Abdeckung mit den Aussparungen für die Knöpfe - und ich habe ein Problem.


    Wie entferne ich das alte Bedienteil, ohne dafür den ganzen Robi zerlegen zu müssen? Bei Youtube findet man ein paar Disassembly-Videos zur 700er-Serie, aber ausgerechnet das Display ist bei den 800ern anders. Beim 700er ist da noch so ein Kunststoffring drum, den man wohl leicht entfernen kann. Wenn der Weg ist, kann man erst den Griff und dann das Display ausklipsen. Das Display vom 800 bekomm ich so allerdings nicht raus. hier sind dieser Ring und das Display eine Einheit. Hab schon leicht dran rumgehebelt, aber das sitzt alles bombenfest und ich will nichts kaputt machen. Hat jemand von euch sachdienliche Hinweise für mich? Gibts vielleicht irgendwo ein 800-series-disassembly Video, das ich übersehen habe?


    Danke für die Hilfe!


    Gruß
    Mangoheini