Posts by Eisha

    Du hast ein Problem in der Verbindung vom Panel zum Board.


    Code
    1. #00003 - 27/09/2020 17:40:00 - [UI] - Communication error, forced STOP button
    2. #00004 - 27/09/2020 17:39:59 - [I2C] Timeout event I2C2 Start


    Mal alle Module abklemmen.


    Man könnte ihn aufschrauben und die Verbindung ab-an-stecken.


    Hoffe er wurde nicht nass gereinigt ... Ansonsten Service.


    Edi sagt: Man bräuchte eine Anzeige im Forum "Jemand anders und wer - schreibt"

    Du kannst jederzeit wieder retur auf eine FW 2.xy siehe Filebase.


    Die Verbindung (config bleibt halbwegs erhalten) steht ja noch von der alten FW. War DHCP oder ?


    Android oder IOS ?

    Mal ein anderes Smartphone probiert?

    Keine Gäste-WLAN bzw der Mäher darf ungehindert raus telefonieren?

    Die anderen Punkte, wie "Geräte dürfen kommunizieren" hast Du auch schon beachtet?

    Sorry für die späte Antwort, aber ich dachte ich müsste was tun und hatte egal keine Zeit.


    Das aktuelle Skript hat bei der Mähzeit eigentlich keine Beschränkung und gibt alle Fahrten aus.

    Bei den Ladezeiten werden nur Ladungen von LOW aus gewertet, dass würde ich aber so lassen. Es geht da ja um die Altersschwäche des Akkus.


    Code
    1. 18/09/2020 15:41:03 - 18/09/2020 16:55:11 - 1242m 74min (32.2°C 16.97V)
    2. 18/09/2020 13:47:07 - 18/09/2020 14:51:53 - 1149m 64min (32.0°C 17.09V)
    3. 18/09/2020 12:00:20 - 18/09/2020 12:58:41 - 893m 58min (23.8°C 17.08V)
    4. 17/09/2020 17:38:16 - 17/09/2020 18:44:36 - 1114m 66min (26.3°C 17.08V)
    5. 17/09/2020 16:30:13 - 17/09/2020 16:43:41 - 223m 13min (29.0°C 16.93V)


    Da bin ich übrigens mit ab und zu noch über 70min hoch zufrieden in der 4. Saison.

    IMU Fehler ist dann quasi ein CPU Fehler ja ?

    Nein, IMU ist ein Kombi-Sensor u.a. für die Lage, Beschleunigung ...

    (der Fehler betrifft ja eher den Bus ic2 an dem auch der IMU hängt)

    ... oder meinste, dass kann daran liegen, dass ich noch die 3.08 FW benutze?

    Nein, das kling nach HW.

    Aber wenn ich Zuhause bin, dann lass ich den mäher auf wenige Prozent runter fahren mit den 5 Ah und hau dann den 6 Ah rein.

    Immer im Wechsel !

    Den Sinn dahinter verstehe ich nicht oder bezweckst Du damit 6h am Stück mähen?

    Ich glaube nicht, dass die Auswertung (Typ, Temp) des Akku über i2c geht. Die 2 Drähte gehen bestimmt direkt zum Board.

    Da Du allerdings mechanisch was am Robi tust könnte es durchaus Auswirkungen haben. (falls Du an einem Modulschacht gegenhälst ;~)

    Ihr merkt aber schon das sich die Witterung verändert hat, oder?


    Meiner hat gestern mal an der LS ein Loch gegraben. Hat er dies Jahr (only FW 3.51) zum ersten Mal gemacht.

    Das Profil ist runter und das Gras viel öfters noch feucht wenn er heim fährt.


    Edit sagt: Außerdem stirbt Poa Annua jetzt gerade mal ;(;(;(

    Durchmesser < 60 sind grenzwertig. Anrempeln darf er nicht bzw. dann gleich nur auf Kollision. Geht bei mir S2017 gut und es bleibt noch weniger Gras stehen.


    Ich halte wenig von der Methode Ausgrenzen (>10 cm) weil man dadurch die Fläche stärker zerstückelt und das Mähergebnis (bei gleicher Zeit) verschlechtert. Bei nur einem Baum in einem ansonsten rechteckigen Mähbereich aber durchaus OK.

    War vielleicht etwas missverständlich formuliert bzw. in den Logs von 2019 wird es etwas anders aufgeführt als früher.


    Das "iotUpdt" ist OK, sind die 10 min Statusmeldungen (IoT Update) vom Mäher.


    Interessant wären andere Einträge wie "appReply" oder ... die darauf hinweisen, dass der Mäher auf eine äußere Anforderung geantwortet hat.


    Wenn ihr eure Logs postet können ja welche mit Erfahrung suchen ob da Nachts was ungewöhnliches passiert.

    Ich hatte m.E. keinen Zeitplan (m/a) aktiv. Er fuhr selbständig um 9:00 Uhr los und überfuhr nach dem erfolgreichen Kantenschnitt im folgenden Mähmodus kurz danach das BK. Beim Auslesen des Logfiles stand bei shedule auch alles mit 0.

    Das klingt verdächtig nach dem Standard-Plan, also dem der ohne alles sowie beim Basic/Landxcape greift.


    Kann man ein Scheduler-"Edit" vom Server zum Mäher anhand der Payload ID im log identifizieren?

    Eher nicht, da immer das komplette MqttJson übertragen wird und sich mWn nur cfg.sc.m "Mode" von x => 0 ändert.


    Hier ging es letztlich um eine unerklärliche Zeitplanänderung, Mein vorletztes log vom 15. zeigt eine leere Tabelle, also deaktivierter Zeitplan, dann gibts nachts ständig WiFi Traffic und am Montag fuhr er los.

    Ich bräuchte Hilfe, um den Wifi Log zu verstehen.

    Wenn man den automatischen Zeitplan deaktiviert hat dürfte mEn keine Trafik von seitens des Servers ausgehen.

    Im Log dürfte dann auch nichts mqtt - schreibend auftauchen, sondern nur ausgehende Nachrichten.


    Nee, eben nicht. Bei mir ändert sich nichts im Zeitplan, wenn ich zwischendurch den Automatischen an hatte.

    Der Server wird wohl nicht sofort reagieren, warum auch.

    Es wird vielmehr zu kA Zeiten geprüft ob was zu ändern ist. Ob da wie beim Update eine zeitlich Lastverteilung greift wiederum kA.


    Letztendlich haben wir nun eine neue Baustelle wo man was verkehrt programmieren kann, also neben den Apps noch den Server. Da gab es früher nur mal den Fehler mit dem Zwangsupdate, ansonsten kam von der Seite nix.

    Nun kann es wohl passieren, dass der Server meint einen neuen Plan verteilen zu müssen obwohl gar kein automatischer Zeitplan aktiv ist.

    Hier wäre interessant was die DA beim Login im Trace bei user und product so an json ausspuckt.

    Da mein S2017 und ich damit sowieso nix anfangen können habe ich mich damit noch nicht intensiv beschäftigt.

    Du hast wohl ein Problem ... onboard



    Das einzige was mir einfallen würde wäre alle Module mal auszubauen und beobachten ob der Fehler dann 3 Tage nicht mehr auftritt.

    Und mal den Akku für 15 min raus nehmen.


    Ansonsten sieht das sehr nach Service aus ... ggf mal mit Log voranfragen.

    Mal ein Log und das mit Analyser-Skript anschauen.

    Die 3.52 fährt per se die erste Ausfahrt kürzer weil keine Vorladung.

    Die Prozente sind auch seit 3.51 für die Tonne orientiere dich besser an der Spannung.